Bug 130772 - postinstall depmod should be in GFS-modules package
Summary: postinstall depmod should be in GFS-modules package
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-24 16:12 UTC by Derek Anderson
Modified: 2010-01-12 02:57 UTC (History)
0 users

Fixed In Version: 6.0.0-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 17:46:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2004-08-24 16:12:19 UTC
Description of problem:
Version: 6.0.0-10

When GFS was split from a single package to two packages (one for
modules) the postinstall scriptlet for 'depmod -a' remained with the
GFS binaries package.  This no longer does anything to benefit the
user; they need to manually depmod (or reboot) after install since the
install order is GFS, then GFS-modules.  So this postinstall scriptlet
should probably be moved to the GFS-modules package.

Version-Release number of selected component (if applicable):
GFS-6.0.0-10

How reproducible:
Yes.

Steps to Reproduce:
1. Remove all GFS packages
2. Install GFS-6.0.0 package
3. Install GFS-modules-6.0.0 package
4. Run modprobe on a GFS module


Actual results:
modprobe: Can't locate module foo


Expected results:
Module loads.

Additional info:

Comment 1 Derek Anderson 2004-08-24 16:18:12 UTC
*** Bug 130773 has been marked as a duplicate of this bug. ***

Comment 2 Jonathan Earl Brassow 2004-08-25 15:16:21 UTC
Should be fixed in GFS-6.0.0-11, which is available in
3.0E-gfs-errata-candidate.



Comment 4 Derek Anderson 2004-09-27 17:46:53 UTC
Verfified: 6.0.0-15.


Note You need to log in before you can comment on or make changes to this bug.