Bug 130773 - postinstall depmod should be in GFS-modules package
postinstall depmod should be in GFS-modules package
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kiersten (Kerri) Anderson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-24 12:17 EDT by Derek Anderson
Modified: 2010-01-11 21:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 16:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-08-24 12:17:01 EDT
Description of problem:
Version: 6.0.0-10

When GFS was split from a single package to two packages (one for
modules) the postinstall scriptlet for 'depmod -a' remained with the
GFS binaries package.  This no longer does anything to benefit the
user; they need to manually depmod (or reboot) after install since the
install order is GFS, then GFS-modules.  So this postinstall scriptlet
should probably be moved to the GFS-modules package.

Version-Release number of selected component (if applicable):
GFS-6.0.0-10

How reproducible:
Yes.

Steps to Reproduce:
1. Remove all GFS packages
2. Install GFS-6.0.0 package
3. Install GFS-modules-6.0.0 package
4. Run modprobe on a GFS module


Actual results:
modprobe: Can't locate module foo


Expected results:
Module loads.

Additional info:
Comment 1 Derek Anderson 2004-08-24 12:18:05 EDT

*** This bug has been marked as a duplicate of 130772 ***
Comment 2 David Lawrence 2004-09-29 16:00:45 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-490.html

Note You need to log in before you can comment on or make changes to this bug.