Bug 1307888 - pypoppler: FTBFS in rawhide
pypoppler: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pypoppler (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
: 1352113 (view as bug list)
Depends On:
Blocks: F24FTBFS 1323497
  Show dependency treegraph
 
Reported: 2016-02-13 17:04 EST by Fedora Release Engineering
Modified: 2016-07-15 06:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: pypoppler-0.12.2-3.fc24 pypoppler-0.12.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-12 11:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (18.88 KB, text/plain)
2016-02-13 17:04 EST, Fedora Release Engineering
no flags Details
root.log (102.77 KB, text/plain)
2016-02-13 17:04 EST, Fedora Release Engineering
no flags Details
state.log (637 bytes, text/plain)
2016-02-13 17:04 EST, Fedora Release Engineering
no flags Details
Remove PopplerOrientation binding from pypoppler (1.03 KB, patch)
2016-04-28 05:16 EDT, Christophe Fergeau
no flags Details | Diff
Patch for 0.12.2 which is currently in rawhide (2.16 KB, patch)
2016-07-01 09:10 EDT, Christophe Fergeau
no flags Details | Diff

  None (edit)
Description Fedora Release Engineering 2016-02-13 17:04:17 EST
Your package pypoppler failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12857875

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-13 17:04:19 EST
Created attachment 1125725 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-13 17:04:20 EST
Created attachment 1125726 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-13 17:04:21 EST
Created attachment 1125727 [details]
state.log
Comment 4 Jan Kurik 2016-02-24 10:00:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Christophe Fergeau 2016-04-28 05:08:19 EDT
This build failure is caused by an upstream change in poppler, see https://bugs.freedesktop.org/show_bug.cgi?id=93229
Comment 6 Christophe Fergeau 2016-04-28 05:16 EDT
Created attachment 1151782 [details]
Remove PopplerOrientation binding from pypoppler

This patch fixes pdfshuffler startup for me. According to poppler upstream, the PopplerOrientation API was unused, so removing it from the python binding might be acceptable. I haven't tried to check if pypoppler users are trying to use this API.
If we want to keep this API in the python binding, https://cgit.freedesktop.org/poppler/poppler/commit/?id=38796894f8ab will have to be reverted from the poppler package.
Comment 7 Christophe Fergeau 2016-04-28 05:16:54 EDT
(In reply to Christophe Fergeau from comment #6)
> This patch fixes pdfshuffler startup for me.

And it fixes the build failure reported in this bug as well.
Comment 8 Christophe Fergeau 2016-07-01 09:10 EDT
Created attachment 1174922 [details]
Patch for 0.12.2 which is currently in rawhide

Updated patch so that it works with pypoppler 0.12.2. Tested pdfshuffler startup with it.
Comment 9 Fedora Update System 2016-07-01 13:02:27 EDT
pypoppler-0.12.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-641c272305
Comment 10 Fedora Update System 2016-07-01 15:36:15 EDT
pypoppler-0.12.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-488e7edc18
Comment 11 Fedora Update System 2016-07-02 16:29:07 EDT
pypoppler-0.12.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-641c272305
Comment 12 Fedora Update System 2016-07-02 16:54:02 EDT
pypoppler-0.12.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-488e7edc18
Comment 13 Fedora Update System 2016-07-12 11:06:31 EDT
pypoppler-0.12.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fabian Affolter 2016-07-14 08:38:24 EDT
*** Bug 1352113 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2016-07-15 06:23:40 EDT
pypoppler-0.12.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.