Bug 1323497 - psdshuffler dies on start
Summary: psdshuffler dies on start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pdfshuffler
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1350076 1351348 (view as bug list)
Depends On: 1307888
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-03 17:07 UTC by Joachim Backes
Modified: 2016-07-15 10:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 15:06:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Backes 2016-04-03 17:07:21 UTC
Description of problem:

Trying to start pdfshuffler fails:

pdfshuffler 
Error: Could not import pdfshuffler
Cause: /usr/lib64/python2.7/site-packages/poppler.so: undefined symbol: poppler_orientation_get_type

Version-Release number of selected component (if applicable):
pdfshuffler-0.6.0-8.fc24.noarch

How reproducible:
always

Steps to Reproduce:
1.See description
2.
3.

Actual results:


Expected results:


Additional info:

Can this be a poppler issue?

Comment 1 Christophe Fergeau 2016-04-28 06:59:47 UTC
poppler-glib apparently lost a symbol without changing its soname, then pypoppler is failing to build in f24, so we are stuck with the f23 package (build failure is https://bugzilla.redhat.com/show_bug.cgi?id=1307888 ), which gives this sad situation :)

Comment 2 Christophe Fergeau 2016-04-28 09:07:35 UTC
This is caused by https://bugs.freedesktop.org/show_bug.cgi?id=93229
Once the build failure is solved and pypoppler is rebuilt for fc24, pdfshuffler works fine (at least start up ;)

Comment 3 Iñigo Serna 2016-06-25 07:17:25 UTC
*** Bug 1350076 has been marked as a duplicate of this bug. ***

Comment 4 Luya Tshimbalanga 2016-07-01 07:48:54 UTC
*** Bug 1351348 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2016-07-01 17:02:31 UTC
pypoppler-0.12.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-641c272305

Comment 6 Fedora Update System 2016-07-01 19:36:18 UTC
pypoppler-0.12.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-488e7edc18

Comment 7 Fedora Update System 2016-07-02 20:29:09 UTC
pypoppler-0.12.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-641c272305

Comment 8 Fedora Update System 2016-07-02 20:54:04 UTC
pypoppler-0.12.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-488e7edc18

Comment 9 Fedora Update System 2016-07-12 15:06:33 UTC
pypoppler-0.12.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-07-15 10:23:43 UTC
pypoppler-0.12.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.