Bug 1308333 - Hosted Engine deployment failed
Summary: Hosted Engine deployment failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-3.6.3
: 1.3.3.3
Assignee: Simone Tiraboschi
QA Contact: cshao
URL:
Whiteboard: integration
Depends On:
Blocks: 1305885
TreeView+ depends on / blocked
 
Reported: 2016-02-14 11:00 UTC by cshao
Modified: 2019-04-28 13:21 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the management bridge already exists on the host as a leftover of a previous deploy attempt, hosted-engine-setup could fail getting the host IP address: fixing it.
Clone Of:
Environment:
Last Closed: 2016-03-11 07:24:23 UTC
oVirt Team: Node
ylavi: ovirt-3.6.z+
ylavi: blocker+
ylavi: planning_ack+
sbonazzo: devel_ack+
gklein: testing_ack+


Attachments (Terms of Use)
/var/log/*.* (198.54 KB, application/x-gzip)
2016-02-14 11:02 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 53428 master MERGED network: fixing hostname - interface enforcing for DHCP setups 2016-02-16 09:33:09 UTC
oVirt gerrit 53434 ovirt-hosted-engine-setup-1.3 MERGED network: fixing hostname - interface enforcing for DHCP setups 2016-02-16 09:33:48 UTC
oVirt gerrit 53607 master MERGED network: getting the IP addr from the bridge if it already exists 2016-02-17 06:31:57 UTC
oVirt gerrit 53614 ovirt-hosted-engine-setup-1.3 MERGED network: getting the IP addr from the bridge if it already exists 2016-02-17 06:34:45 UTC

Description cshao 2016-02-14 11:00:18 UTC
Description of problem:
Hosted Engine deployment failed.

[ INFO  ] Stage: Setup validation
[ ERROR ] Failed to execute stage 'Setup validation': Cannot acquire nic/bond/vlan address
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160214025020.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed: this system is not reliable, please check the issue, fix and redeploy
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160214024350-n1jgll.log
Something went wrong setting up hosted engine, or the setup process was cancelled.

Press any key to continue...

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20160212.0 
ovirt-node-3.6.1-6.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-7.el7ev.noarch
ovirt-hosted-engine-setup-1.3.3.1-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.4.0-1.el7ev.noarch
rhev-m appliance:20160212.0-1.3.6.ova  

How reproducible:
100%

Steps to Reproduce:
1. TUI clean install rhevh on local machine.
2. Login rhevh, setup network via dhcp.
3. Switch to HE menu.
4. File the OVA URL.
5. Configure Hosted engine with default option(storage:NFS type).
6. Try to Finish HE configure.

Actual results:
Hosted Engine deployment failed.

Expected results:
Hosted Engine deployment pass.

Additional info:
No such issue with rhev-hypervisor7-7.2-20160212.0 + rhevm-appliance-20160120.0-1.3.6.ova.

Comment 1 cshao 2016-02-14 11:02:00 UTC
Add regression keyword due to no such issue with rhev-hypervisor7-7.2-20160212.0 + rhevm-appliance-20160120.0-1.3.6.ova.

Comment 2 cshao 2016-02-14 11:02:32 UTC
Created attachment 1127015 [details]
/var/log/*.*

Comment 4 Simone Tiraboschi 2016-02-16 18:04:48 UTC
It still fails if the management bridge is already there since a previous failed attempt.
Adding another path to address that.
Workaround to this specific sub-issue: manually remove the management bridge before the next attempt with hosted-engine-setup.

Comment 5 Red Hat Bugzilla Rules Engine 2016-02-16 18:04:57 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 6 cshao 2016-02-24 11:52:41 UTC
Test version:
rhev-hypervisor7-7.2-20160222.0
ovirt-node-3.6.1-7.0.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-7.el7ev.noarch
ovirt-node-plugin-vdsm-0.6.1-7.el7ev.noarch
ovirt-hosted-engine-setup-1.3.3.3-1.el7
ovirt-hosted-engine-ha-1.3.4.1-1.el7
rhev-m appliance:20160212.0-1.3.6.ova  


Test steps:
1. TUI clean install rhevh on local machine.
2. Login rhevh, setup network via dhcp.
3. Switch to HE menu.
4. File the OVA URL.
5. Configure Hosted engine with default option(storage:NFS type).
6. Finish HE configure.

Test result:
Hosted Engine deployment pass.

So the bug is fixed, change bug status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.