Bug 1308410 - DHT :- log is full of ' Found anomalies in /<DIR> (gfid = 00000000-0000-0000-0000-000000000000)' - for each Directory which was self healed
DHT :- log is full of ' Found anomalies in /<DIR> (gfid = 00000000-0000-0000...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Sakshi
:
Depends On: 1114045 1281265
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-15 01:34 EST by Sakshi
Modified: 2016-04-19 03:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1281265
Environment:
Last Closed: 2016-04-15 01:14:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2016-02-15 01:34:05 EST
+++ This bug was initially created as a clone of Bug #1281265 +++

+++ This bug was initially created as a clone of Bug #1114045 +++

Description of problem:
=======================
cause of any reasons if Directory has been self healed, log has below messages where 0 GFIDs are dumped in the log rather than the actual GFID of the directory.

:[2014-06-25 08:52:50.339861] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /zile (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0




Version-Release number of selected component (if applicable):
=============================================================
3.6.0.19-1.el6rhs.x86_64

How reproducible:
=================
always

Steps to Reproduce:
===================
1.Create and mount Distributed Volume
2. Create Directories from mount point and make sure It is not created on all up sub-volumes.
3. send lookup from another mount point.
4. check logs for self-healed Directory 0 GFIDs are dumped rather than actual

Actual results:
===============
[2014-06-25 08:52:50.339861] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /zile (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0

Expected results:
=================
should show Actual GFID of Directory


Additional info:
================


[root@OVM3 nfs]# gluster v status snap
Status of volume: snap
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick 10.70.35.198:/brick2/b1				49157	Y	13611
Brick 10.70.35.198:/brick2/b2				49158	Y	13345
Brick 10.70.35.198:/brick2/b3				49159	Y	13356
NFS Server on localhost					2049	Y	13623
NFS Server on 10.70.35.240				2049	Y	19185
NFS Server on 10.70.35.172				2049	Y	13465
 
Task Status of Volume snap
------------------------------------------------------------------------------
There are no active volume tasks

log snippet:-
[2014-06-27 07:53:07.260193] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /dir2 (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0
[2014-06-27 07:56:39.896560] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /dir2 (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0
[2014-06-27 08:02:41.481429] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /dir2 (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0
[2014-06-27 08:04:39.932597] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /dir2 (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0
[2014-06-27 08:06:52.812528] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /dir2 (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0
[2014-06-27 08:08:59.461588] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /abc (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0
[2014-06-27 10:21:46.216573] I [dht-layout.c:663:dht_layout_normalize] 0-snap-dht: Found anomalies in /abc (gfid = 00000000-0000-0000-0000-000000000000). Holes=1 overlaps=0

--- Additional comment from Vijay Bellur on 2015-11-12 03:14:55 EST ---

REVIEW: http://review.gluster.org/12574 (dht: loc should store proper gfid) posted (#1) for review on master by Sakshi Bansal

--- Additional comment from Vijay Bellur on 2015-11-17 04:46:44 EST ---

COMMIT: http://review.gluster.org/12574 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit b6323c1995223d3566ffca12145c943df3fdc2ed
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Thu Nov 12 13:43:31 2015 +0530

    dht: loc should store proper gfid
    
    Change-Id: Ic1393d44a9ed4aaba23d7c9ddea45977b9dae5e4
    BUG: 1281265
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/12574
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 1 Vijay Bellur 2016-02-15 01:37:06 EST
REVIEW: http://review.gluster.org/13443 (dht: loc should store proper gfid) posted (#1) for review on release-3.7 by Sakshi Bansal
Comment 2 Vijay Bellur 2016-02-15 01:37:50 EST
REVIEW: http://review.gluster.org/13443 (dht: loc should store proper gfid) posted (#2) for review on release-3.7 by Sakshi Bansal
Comment 3 Vijay Bellur 2016-02-23 03:28:12 EST
COMMIT: http://review.gluster.org/13443 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit f3b120bd994321592d5c148d968d9b8f55411a8d
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Thu Nov 12 13:43:31 2015 +0530

    dht: loc should store proper gfid
    
    Backport of  http://review.gluster.org/12574
    
    > Change-Id: Ic1393d44a9ed4aaba23d7c9ddea45977b9dae5e4
    > BUG: 1281265
    > Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    > Reviewed-on: http://review.gluster.org/12574
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    BUG: 1308410
    Change-Id: I6577971f3db139eccf3b8ca3b25e66d292a6a150
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/13443
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Kaushal 2016-04-19 03:23:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.