Bug 130852 - php-mbstring seems broken, functions are missing
php-mbstring seems broken, functions are missing
Status: CLOSED DUPLICATE of bug 127518
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-25 06:01 EDT by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2004-08-25 06:01:55 EDT
Description of problem:
When trying to use php-mailparse, which depends on some mbstring
functions, the module fails to load with an "undefined symbol:
mbfl_convert_filter_new" error.

Version-Release number of selected component (if applicable):
php-4.3.8-2.1 and php-mbstring-4.3.8-2.1

How reproducible:
Always.

Steps to Reproduce:
1. Recompile mailparse.so from http://pecl.php.net/ (compiles fine)
2. Load the module after the mbstring.so one
3. Run "php" on the command line
  
Actual results:
$ php
PHP Warning:  Unknown(): Unable to load dynamic library
'/usr/lib/php4/mailparse.so' - /usr/lib/php4/mailparse.so: undefined
symbol: mbfl_convert_filter_new in Unknown on line 0

Expected results:
$ php


Additional info:
When trying to load the mbstring module twice, I get plenty of
warnings like these :
PHP Warning:  Function registration failed - duplicate name -
mb_convert_case in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
mb_strtoupper in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
mb_strtolower in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
mb_language in Unknown on line 0
[...]
None of which are mbfl_convert_* names. Running "strings" on the
mbstrings.so library does show many mbfl_convert_* names, though.

This is with the errata php, the original 4.3.6 (where mbstring was
built-in) worked fine.

I've reported this bug first to the upstream mailpase developer, and
he is not aware of any incompatibility with php 4.3.8 and his
conclusion was that the Fedora Core 2 errata is broken wrt mbstring.
Comment 1 Joe Orton 2004-08-25 06:10:22 EDT
This is broken by the way modules are loaded in the FC2 PHP package.
Some proprietary Zend modules are broken by this but we were yet to
see any examples of open source modules having the same problem.

So now you've found an example, and we'll revert the change for the
next release.  (if you rebuild the source RPM without the -dlopen
patch applied it will work)

Thanks a lot for the report.


*** This bug has been marked as a duplicate of 127518 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.