Bug 130856 - Request for gdbm to be added to dba
Summary: Request for gdbm to be added to dba
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-25 11:02 UTC by Matthias Saou
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 11:26:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Saou 2004-08-25 11:02:08 UTC
Description of problem:
Gdbm support isn't included in the dba module, and can't be easily
added as dba is built-in in the current php packages.

Version-Release number of selected component (if applicable):
php-4.3.8-2.1 (previous versions too)

How reproducible:
Always (none of the previous FC2 php packages had gdbm support either).
  
Additional info:
See : http://www.php.net/manual/en/ref.dba.php
Apparently, dbm and ndbm are marked as to be avoided, but not gdbm.
It's still supported, works well, and doesn't add too many more
dependencies (gdbm-devel at build time and gdbm at runtime).
The main concern is that since the dba module is built-in, it can't be
easily replaced. Currently to add gdbm support I must replace the main
php package with one rebuilt without the explicit '--without-gdbm'
configure option.
If a new errata will be made for bug #127518 maybe this could go in
too? It shouldn't be possible for such a minor change to cause
breakage. I'm still curious as to why gdbm was disabled in the first
place, though.

Comment 1 Joe Orton 2004-08-25 11:26:20 UTC
It was removed because the PHP license is not compatible with the GPL.


Note You need to log in before you can comment on or make changes to this bug.