Bug 1308611 - pxe boot timed on baremetal nodes during overcloud introspection
pxe boot timed on baremetal nodes during overcloud introspection
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: ipxe (Show other bugs)
7.0 (Kilo)
All All
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: RHOS Maint
Raviv Bar-Tal
: Reopened, TestOnly
: 1308646 (view as bug list)
Depends On: 1301694
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-15 10:39 EST by Jaromir Coufal
Modified: 2016-07-25 10:26 EDT (History)
23 users (show)

See Also:
Fixed In Version: ipxe-20160127-1.git6366fa7a.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1301694
Environment:
Last Closed: 2016-07-25 10:26:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Dmitry Tantsur 2016-02-16 04:38:24 EST
*** Bug 1308646 has been marked as a duplicate of this bug. ***
Comment 2 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 3 Dmitry Tantsur 2016-04-08 04:01:25 EDT
I'm not entirely convinced, but I we're shipping the new ROM, and the problem might be fixed now.
Comment 5 Dan Yocum 2016-04-12 15:48:07 EDT
I have tried 3 different "versions" of undionly.kpxe and none work reliably on Dell r630 or r730xd systems:


[stack@ops2 tftpboot]$ cksum undionly.kpxe*
157772169 64120 undionly.kpxe
4250223444 63895 undionly.kpxe.2016-04-12
750298637 63517 undionly.kpxe.bak
Comment 6 Dan Yocum 2016-04-12 17:09:46 EDT
This issue persists in OSP-d v8.
Comment 11 Dan Yocum 2016-04-21 10:45:58 EDT
I can verify that the Dell R630 and R730xd systems with Intel X520 i350 nics are booting properly using the following ROMS:

ipxe-bootimgs-20160127-1.git6366fa7a.el7.noarch

NB: the git hash should match the ipxe version hash displayed when chainloading.
Comment 12 Raviv Bar-Tal 2016-07-21 07:54:29 EDT
new parameter is introduce to the  /httpboot/inspector.ipxe
The parameter --timeout 60000, in case download freeze for 60 seconds it will restart again.

see https://bugzilla.redhat.com/show_bug.cgi?id=1337250 for more details

Note You need to log in before you can comment on or make changes to this bug.