Bug 1308808 - hamster-time-tracker not starting due to Gtk error
hamster-time-tracker not starting due to Gtk error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hamster-time-tracker (Show other bugs)
23
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 02:19 EST by lefred
Modified: 2016-02-16 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 08:22:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lefred 2016-02-16 02:19:32 EST
Description of problem:

When hamster is run, it fails with the following error:

$ hamster
/usr/lib/python2.7/site-packages/hamster/lib/stuff.py:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk as gtk
/usr/lib/python2.7/site-packages/hamster/lib/configuration.py:33: PyGIWarning: GConf was imported without specifying a version first. Use gi.require_version('GConf', '2.0') before import to ensure that the right version gets loaded.
  from gi.repository import GConf as gconf
Traceback (most recent call last):
  File "/usr/bin/hamster", line 387, in <module>
    hamster_client.overview()
  File "/usr/bin/hamster", line 152, in overview
    self._launch_window("overview")
  File "/usr/bin/hamster", line 143, in _launch_window
    getattr(server, window_name)()
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.ImportError: Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/bin/hamster-windows-service", line 38, in overview
    def overview(self): dialogs.overview.show(self.app)
  File "/usr/lib/python2.7/site-packages/hamster/configuration.py", line 106, in show
  File "/usr/lib/python2.7/site-packages/hamster/configuration.py", line 132, in get_overview_class
  File "/usr/lib/python2.7/site-packages/hamster/overview.py", line 27, in <module>
    from gi.repository import Gtk as gtk
  File "/usr/lib64/python2.7/site-packages/gi/__init__.py", line 39, in <module>
    raise ImportError(_static_binding_error)
ImportError: When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject". See: https://bugzilla.gnome.org/show_bug.cgi?id=709183


Version-Release number of selected component (if applicable):

hamster-time-tracker-2.0-0.2.rc1.fc23.noarch
pythopython-gobject-base-3.18.2-1.fc23.x86_64

How reproducible:

every time


Steps to Reproduce:
1. just run hamster in cli after having performed dnf update 

Actual results:

error entered above

Expected results:

it should run ;)

Additional info:
Comment 1 lefred 2016-02-16 07:56:52 EST
After a reboot of the system, I've a error even more scary:

 $ hamster-service 
/usr/lib/python2.7/site-packages/hamster/lib/stuff.py:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk as gtk
/usr/lib/python2.7/site-packages/hamster/idle.py:24: PyGIWarning: GConf was imported without specifying a version first. Use gi.require_version('GConf', '2.0') before import to ensure that the right version gets loaded.
  from gi.repository import GConf as gconf
hamster-service up
Segmentation fault (core dumped)
Comment 2 Felix Schwarz 2016-02-16 08:03:16 EST
If I'm not mistaken you are using a faulty version which unfortunately made it into stable. See bug 1307253 for downgrading instructions or try hamster-time-tracker-2.0-0.3.rc1.fc23 which should be available via updates-testing.
Comment 3 lefred 2016-02-16 08:22:58 EST
I've tired the last one (from https://bodhi.fedoraproject.org/updates/FEDORA-2016-7d556fdafa) and it works !

Thank you.
Comment 4 Raphael Groner 2016-02-16 13:46:09 EST
I fail to see any urgency but I'm happy to see the new update works for you.
Comment 5 lefred 2016-02-16 18:22:39 EST
It was "urgent" because it created a segfault and I was not able to use this tool which is very important for my daily work ;-)

thank you for the fix.

Note You need to log in before you can comment on or make changes to this bug.