Bug 1309113 - [RFE] Multi-Site v2 for Disaster Recovery
Summary: [RFE] Multi-Site v2 for Disaster Recovery
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 1.3.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Yehuda Sadeh
QA Contact: shilpa
Bara Ancincova
URL:
Whiteboard:
: 1263292 (view as bug list)
Depends On:
Blocks: 1322504
TreeView+ depends on / blocked
 
Reported: 2016-02-16 22:12 UTC by Neil Levine
Modified: 2019-12-16 05:24 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Documented with BZ#1265797
Clone Of:
Environment:
Last Closed: 2016-08-23 19:30:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1265797 unspecified CLOSED [RFE] Multi-site v2 for active-active read/write 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Internal Links: 1265797

Description Neil Levine 2016-02-16 22:12:34 UTC
This BZ will track the QE and Docs for deploying RGW with the new Multisite v2 architecture for disaster recovery use-cases between two sites.

As an admin, I deploy a master site which my end-users read and write objects to via RGW.

As an admin, I deploy a second site for disaster recovery purposes and slave all RGW content from the master site but does not receive end-user read or writes.

As an an admin, I manually choose to failover to the secondary site via a change to DNS for my end-users.

As an admin, I recover the failed site and resync it with the backup site and restore it to being master.

Comment 2 Ken Dreyer (Red Hat) 2016-02-29 23:08:52 UTC
Is this a dup of 1265797?

Comment 5 Yehuda Sadeh 2016-05-09 20:43:57 UTC
*** Bug 1263292 has been marked as a duplicate of this bug. ***

Comment 6 shilpa 2016-07-28 15:25:28 UTC
Ref doc: http://10.34.3.139:8080/view/Ceph/job/doc-Red_Hat_Ceph_Storage_2-Object_Gateway%20-%20RHEL%20%28html-single%29/lastSuccessfulBuild/artifact/RHEL/index.html#_configuring_a_master_zone

In the section "Create a Master Zone", the zone should be configured with an endpoint:

#radosgw-admin zone create --rgw-zonegroup={zone-group-name} --rgw-zone={zone-name} --master --default

Should be changed to:

#radosgw-admin zone create --rgw-zonegroup={zone-group-name}  --endpoints=http://rgw1:80 --rgw-zone={zone-name} --master --default

Comment 9 rakesh 2016-08-08 07:39:01 UTC
The document changes asked here are being followed up in a separate doc bug ( https://bugzilla.redhat.com/show_bug.cgi?id=1321892 ). And as of APDR, the functionality is working fine. So moving this bug to verified state.

Comment 11 errata-xmlrpc 2016-08-23 19:30:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755


Note You need to log in before you can comment on or make changes to this bug.