Bug 1309191 - [RFE] Schedule Geo-replication
[RFE] Schedule Geo-replication
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On: 1300956
Blocks: 1209521 glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-17 01:53 EST by Aravinda VK
Modified: 2016-04-19 03:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300956
Environment:
Last Closed: 2016-03-22 04:14:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-02-17 01:53:42 EST
+++ This bug was initially created as a clone of Bug #1300956 +++

Description of problem:
Add new feature to schedule Geo-replication when required. Instead of running always, schedule to run once a day or twice a day.

--- Additional comment from Vijay Bellur on 2016-01-22 03:52:43 EST ---

REVIEW: http://review.gluster.org/13279 (geo-rep: Script to Schedule Geo-replication) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-28 05:00:15 EST ---

REVIEW: http://review.gluster.org/13279 (geo-rep: Script to Schedule Geo-replication) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-04 07:51:14 EST ---

REVIEW: http://review.gluster.org/13279 (geo-rep: Script to Schedule Geo-replication) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-17 01:27:52 EST ---

COMMIT: http://review.gluster.org/13279 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit d7e052ee24b3e09f2e76c2fdb980e33e74d2a855
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Jan 22 12:11:18 2016 +0530

    geo-rep: Script to Schedule Geo-replication
    
    This script can be used to run Geo-replication when required. can be
    scheduled using cron job to run Geo-replication.
    
    This script does the following,
      1. Stop Geo-replication if Started
      2. Start Geo-replication
      3. Set Checkpoint
      4. Check the Status and see Checkpoint is Complete.(LOOP)
      5. If checkpoint complete, Stop Geo-replication
    
    Usage:
        python /usr/share/glusterfs/scripts/schedule_georep.py <MASTERVOL> \
                 <SLAVEHOST> <SLAVEVOL>
    
    For example,
        python /usr/share/glusterfs/scripts/schedule_georep.py gv1 fvm1 gv2
    
    To schedule the Geo-replication to run once in a day using cron,
       # Run daily at 08:30pm
       30 20 * * * root python /usr/share/glusterfs/scripts/schedule_georep.py \
          --no-color gv1 fvm1 gv2 >> /var/log/glusterfs/schedule_georep.log 2>&1
    
    BUG: 1300956
    Change-Id: I6b1e2ddbf7fc09ef621499b57ae230fd4dbbd9a6
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13279
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 1 Vijay Bellur 2016-02-24 07:52:19 EST
REVIEW: http://review.gluster.org/13510 (geo-rep: Script to Schedule Geo-replication) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2016-02-26 02:17:59 EST
REVIEW: http://review.gluster.org/13510 (geo-rep: Script to Schedule Geo-replication) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2016-02-29 00:58:36 EST
REVIEW: http://review.gluster.org/13510 (geo-rep: Script to Schedule Geo-replication) posted (#3) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 4 Vijay Bellur 2016-03-08 05:00:09 EST
COMMIT: http://review.gluster.org/13510 committed in release-3.7 by Aravinda VK (avishwan@redhat.com) 
------
commit eae63bbcdaf6ec6ae5340b51bd05c476c791e38b
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Feb 24 18:18:12 2016 +0530

    geo-rep: Script to Schedule Geo-replication
    
    This script can be used to run Geo-replication when required. can be
    scheduled using cron job to run Geo-replication.
    
    This script does the following,
      1. Stop Geo-replication if Started
      2. Start Geo-replication
      3. Set Checkpoint
      4. Check the Status and see Checkpoint is Complete.(LOOP)
      5. If checkpoint complete, Stop Geo-replication
    
    Usage:
        python /usr/share/glusterfs/scripts/schedule_georep.py <MASTERVOL> \
                     <SLAVEHOST> <SLAVEVOL>
    
    For example,
        python /usr/share/glusterfs/scripts/schedule_georep.py gv1 fvm1 gv2
    
    To schedule the Geo-replication to run once in a day using cron,
       # Run daily at 08:30pm
          30 20 * * * root python /usr/share/glusterfs/scripts/schedule_georep.py \
                --no-color gv1 fvm1 gv2 >> /var/log/glusterfs/schedule_georep.log 2>&1
    
    BUG: 1309191
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13279
    Change-Id: Ie1507be00afd9ff189bb1664b156328dced4076a
    Reviewed-on: http://review.gluster.org/13510
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
Comment 5 Kaushal 2016-04-19 03:21:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.