Bug 1309223 - firebird-devel does not contain /usr/sbin/fb_config anymore
firebird-devel does not contain /usr/sbin/fb_config anymore
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firebird (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Philippe Makowski
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 04:21 EST by David Tardon
Modified: 2016-02-22 20:23 EST (History)
2 users (show)

See Also:
Fixed In Version: firebird-2.5.5.26952.0-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 20:23:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tardon 2016-02-17 04:21:54 EST
Description of problem:
firebird-devel no longer contains /usr/bin/fb_config. This breaks build of any package that uses firebird and uses fb_config in configure.

Version-Release number of selected component (if applicable):
firebird-2.5.5.26952.0-1.fc23

How reproducible:
always

Steps to Reproduce:
1. install firebird-devel
2. ls /usr/bin/fb_config

Expected results:
fb_config is present

Additional info:
/usr/bin/fb_config is in firebird package--where it has no place, because it is a development tool--because of %{_bindir}/* in %files. There should either be an %exclude or an explicit list of binaries there and %{_bindir}/fb_config should be moved to firebird-devel.

And if you want to keep bug 1297506 fixed, please see
https://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks#Multiarch.2C_binaries_and_compilation_scripts
for how to really do that.
Comment 1 Fedora Update System 2016-02-20 07:57:55 EST
firebird-2.5.5.26952.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-920f8af29c
Comment 2 Fedora Update System 2016-02-21 12:58:24 EST
firebird-2.5.5.26952.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-920f8af29c
Comment 3 Fedora Update System 2016-02-22 20:23:10 EST
firebird-2.5.5.26952.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.