Bug 1309281 - nova.virt.libvirt.driver fails to shutdown reboot instance with error 'Code=38 Error=Failed to terminate process 4260 with SIGKILL: Device or resource busy'
nova.virt.libvirt.driver fails to shutdown reboot instance with error 'Code=3...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
All Linux
urgent Severity urgent
: async
: 6.0 (Juno)
Assigned To: Kashyap Chamarthy
Prasanth Anbalagan
: ZStream
: 1309280 (view as bug list)
Depends On: 1205647
Blocks: 1303075 1304081
  Show dependency treegraph
 
Reported: 2016-02-17 06:34 EST by Pablo Iranzo Gómez
Modified: 2016-04-18 11:04 EDT (History)
17 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-59.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1205647
Environment:
Last Closed: 2016-04-18 11:04:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1609683 None None None 2016-02-17 06:34 EST

  None (edit)
Comment 2 Pablo Iranzo Gómez 2016-02-17 06:38:38 EST
*** Bug 1309280 has been marked as a duplicate of this bug. ***
Comment 24 Prasanth Anbalagan 2016-04-12 20:50:23 EDT
Verified as follows

**************
VERSION
**************

[root@lynx13 ~(keystone_admin)]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            2014.2.3-66.el7ost      @rhelosp-6.0-puddle
openstack-nova-cert.noarch           2014.2.3-66.el7ost      @rhelosp-6.0-puddle
openstack-nova-common.noarch         2014.2.3-66.el7ost      @rhelosp-6.0-puddle
openstack-nova-conductor.noarch      2014.2.3-66.el7ost      @rhelosp-6.0-puddle
openstack-nova-console.noarch        2014.2.3-66.el7ost      @rhelosp-6.0-puddle
openstack-nova-novncproxy.noarch     2014.2.3-66.el7ost      @rhelosp-6.0-puddle
openstack-nova-scheduler.noarch      2014.2.3-66.el7ost      @rhelosp-6.0-puddle
[root@lynx13 ~(keystone_admin)]# 


***********
LOGS
***********

[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+--------+------------+-------------+---------------------+
| ID                                   | Name | Status | Task State | Power State | Networks            |
+--------------------------------------+------+--------+------------+-------------+---------------------+
| 7d792139-0dc6-4650-993e-22f7476286aa | vm1  | ACTIVE | -          | Running     | public=172.24.4.230 |
| 80315579-1b2b-4e91-83ea-f428d2bc2ae3 | vm2  | ACTIVE | -          | Running     | public=172.24.4.229 |
+--------------------------------------+------+--------+------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# nova stop vm1
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+---------+------------+-------------+---------------------+
| ID                                   | Name | Status  | Task State | Power State | Networks            |
+--------------------------------------+------+---------+------------+-------------+---------------------+
| 7d792139-0dc6-4650-993e-22f7476286aa | vm1  | SHUTOFF | -          | Shutdown    | public=172.24.4.230 |
| 80315579-1b2b-4e91-83ea-f428d2bc2ae3 | vm2  | ACTIVE  | -          | Running     | public=172.24.4.229 |
+--------------------------------------+------+---------+------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# nova start vm1
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+---------+-------------+-------------+---------------------+
| ID                                   | Name | Status  | Task State  | Power State | Networks            |
+--------------------------------------+------+---------+-------------+-------------+---------------------+
| 7d792139-0dc6-4650-993e-22f7476286aa | vm1  | SHUTOFF | powering-on | Shutdown    | public=172.24.4.230 |
| 80315579-1b2b-4e91-83ea-f428d2bc2ae3 | vm2  | ACTIVE  | -           | Running     | public=172.24.4.229 |
+--------------------------------------+------+---------+-------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+--------+------------+-------------+---------------------+
| ID                                   | Name | Status | Task State | Power State | Networks            |
+--------------------------------------+------+--------+------------+-------------+---------------------+
| 7d792139-0dc6-4650-993e-22f7476286aa | vm1  | ACTIVE | -          | Running     | public=172.24.4.230 |
| 80315579-1b2b-4e91-83ea-f428d2bc2ae3 | vm2  | ACTIVE | -          | Running     | public=172.24.4.229 |
+--------------------------------------+------+--------+------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# nova suspend vm1
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+-----------+------------+-------------+---------------------+
| ID                                   | Name | Status    | Task State | Power State | Networks            |
+--------------------------------------+------+-----------+------------+-------------+---------------------+
| 7d792139-0dc6-4650-993e-22f7476286aa | vm1  | SUSPENDED | -          | Shutdown    | public=172.24.4.230 |
| 80315579-1b2b-4e91-83ea-f428d2bc2ae3 | vm2  | ACTIVE    | -          | Running     | public=172.24.4.229 |
+--------------------------------------+------+-----------+------------+-------------+---------------------+
[root@lynx13 ~(keystone_admin)]# nova resume vm1
[root@lynx13 ~(keystone_admin)]# 
[root@lynx13 ~(keystone_admin)]# nova list
+--------------------------------------+------+--------+------------+-------------+---------------------+
| ID                                   | Name | Status | Task State | Power State | Networks            |
+--------------------------------------+------+--------+------------+-------------+---------------------+
| 7d792139-0dc6-4650-993e-22f7476286aa | vm1  | ACTIVE | -          | Running     | public=172.24.4.230 |
| 80315579-1b2b-4e91-83ea-f428d2bc2ae3 | vm2  | ACTIVE | -          | Running     | public=172.24.4.229 |
+--------------------------------------+------+--------+------------+-------------+---------------------+
Comment 26 errata-xmlrpc 2016-04-18 11:04:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0639.html

Note You need to log in before you can comment on or make changes to this bug.