Bug 1309293 - Failed to syncDbRecords after successful live merge because host is down
Failed to syncDbRecords after successful live merge because host is down
Status: CLOSED DUPLICATE of bug 1309294
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.5
: ---
Assigned To: Allon Mureinik
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 07:00 EST by Ala Hino
Modified: 2016-02-18 06:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:45:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Ala Hino 2016-02-17 07:00:50 EST
Description of problem:
After successful live merge, if during host goes down after completion of live merge but before calling 'syncDbRecords', flow fails because 'syncDbRecords' calls vdsm to get image info.

This bug is to make sure we remove the call to vdsm outside of 'syncDbRecords'.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. (Lively) remove a snapshot
2. After/before DESTROY_IMAGE_CHECK completes, take shutdown host
3. Update the db fails

Actual results:
Db update fails

Expected results:
Db to be updated with the correct data regarding live merge

Additional info:
Comment 1 Allon Mureinik 2016-02-18 06:45:52 EST
This seems like the double-submit issue in bugzilla again. Since bug 1309294 already has some activity, I'm closing this one.

Ala, if this analysis is incorrect, please explain and reopen.

*** This bug has been marked as a duplicate of bug 1309294 ***
Comment 2 Ala Hino 2016-02-18 06:54:35 EST
Exactly the same, probably second one created by mistake

Note You need to log in before you can comment on or make changes to this bug.