Bug 1309294 - Failed to syncDbRecords after successful live merge because host is down
Failed to syncDbRecords after successful live merge because host is down
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Ala Hino
Elad
:
: 1309293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 07:01 EST by Ala Hino
Modified: 2016-04-21 10:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:39:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
ylavi: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53606 master MERGED core: Handle exception if calling VDSM fails 2016-02-23 09:50 EST
oVirt gerrit 54132 ovirt-engine-3.6 MERGED refactor: Split syncDbRecords code 2016-03-02 05:02 EST
oVirt gerrit 54133 ovirt-engine-3.6 MERGED core: Wrap syncDbRecords code in a transaction 2016-03-02 05:03 EST
oVirt gerrit 54134 ovirt-engine-3.6 MERGED core: Move getImageInfo call outside of transaction boundary 2016-03-02 05:05 EST
oVirt gerrit 54135 ovirt-engine-3.6 MERGED core: Handle exception if calling VDSM fails 2016-03-02 05:06 EST
oVirt gerrit 54136 ovirt-engine-3.6 MERGED core: Remove index from curly braces 2016-03-02 05:07 EST

  None (edit)
Description Ala Hino 2016-02-17 07:01:23 EST
Description of problem:
After successful live merge, if during host goes down after completion of live merge but before calling 'syncDbRecords', flow fails because 'syncDbRecords' calls vdsm to get image info.

This bug is to make sure we remove the call to vdsm outside of 'syncDbRecords'.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. (Lively) remove a snapshot
2. After/before DESTROY_IMAGE_CHECK completes, take shutdown host
3. Update the db fails

Actual results:
Db update fails

Expected results:
Db to be updated with the correct data regarding live merge

Additional info:
Comment 1 Allon Mureinik 2016-02-18 06:45:52 EST
*** Bug 1309293 has been marked as a duplicate of this bug. ***
Comment 2 Allon Mureinik 2016-02-28 08:26:54 EST
This patch should be backported to the ovirt-engine-3.6 branch. Setting the status back to POST.
Comment 3 Elad 2016-04-04 08:26:58 EDT
Tested the following on 2 builds:
rhevm-3.6.3-0.1.el6.noarch - doesn't contain the fix
rhevm-3.6.5-0.1.el6.noarch - contains the fix


1. Remove a snapshot lively
2. After DESTROY_IMAGE_CHECK completes, stopped vdsm

On the older build, the volume became Illegal and on the latest it got removed.

Note You need to log in before you can comment on or make changes to this bug.