Bug 1309357 - Search for modules does not work, only first 20 modules available for CV
Search for modules does not work, only first 20 modules available for CV
Status: CLOSED DUPLICATE of bug 1347792
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Tom McKay
http://projects.theforeman.org/issues...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 10:33 EST by Tom McKay
Modified: 2016-07-06 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-06 13:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13163 None None None 2016-04-22 11:34 EDT

  None (edit)
Description Tom McKay 2016-02-17 10:33:52 EST
Centos 7.2, x86_64, all updates applied as of today, selinux restrictive.

katello-certs-tools-2.4.0-1.el7.noarch
katello-common-2.4.0-7.el7.noarch
pulp-katello-0.4-3.el7.noarch
katello-selinux-2.2.2-1.el7.noarch
tfm-rubygem-hammer_cli_katello-0.0.18-3.el7.noarch
tfm-rubygem-katello-2.4.0-3.el7.noarch
katello-2.4.0-7.el7.noarch
katello-repos-2.4.0-5.el7.noarch
katello-default-ca-1.0-1.noarch
katello-debug-2.4.0-7.el7.noarch
katello-installer-2.4.0-1.rc3.el7.noarch
katello-service-2.4.0-7.el7.noarch
katello-server-ca-1.0-1.noarch
katello-installer-base-2.4.0-1.rc3.el7.noarch

as plugin for the recent stable foreman:

foreman-release-scl-1-1.el7.x86_64
foreman-selinux-1.10.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.el7.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_10.el7.noarch
foreman-debug-1.10.0-1.el7.noarch
foreman-release-1.10.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-1.10.0-1.el7.noarch
foreman-compute-1.10.0-1.el7.noarch
foreman-postgresql-1.10.0-1.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-foreman-tasks-0.7.10-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-libvirt-1.10.0-1.el7.noarch
foreman-vmware-1.10.0-1.el7.noarch
foreman-proxy-1.10.0-1.el7.noarch
foreman-gce-1.10.0-1.el7.noarch
foreman-ovirt-1.10.0-1.el7.noarch

I have added forge.puppetlabs.com as a repository for puppet module, a sync seems to be working, more than 3.8k modules available in my installation. Although the sync works and the modules are available, I only can select the first 20 (as sorted alphabetically) when trying to add modules to a CV. When one module is added, the 21st, then 20th module is available also. Searching does not work.
Comment 1 Tom McKay 2016-02-17 10:33:54 EST
Created from redmine issue http://projects.theforeman.org/issues/13163
Comment 5 Bryan Kearney 2016-02-18 08:10:07 EST
Upstream bug assigned to tomckay@redhat.com
Comment 6 Bryan Kearney 2016-02-18 08:10:09 EST
Upstream bug assigned to tomckay@redhat.com
Comment 8 Tom McKay 2016-07-06 13:40:35 EDT

*** This bug has been marked as a duplicate of bug 1347792 ***

Note You need to log in before you can comment on or make changes to this bug.