Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1347792 - Unable to add puppet module stdlib to my content view through the UI
Summary: Unable to add puppet module stdlib to my content view through the UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1309357 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 16:23 UTC by Justin Sherrill
Modified: 2019-09-25 21:19 UTC (History)
5 users (show)

Fixed In Version: rubygem-katello-3.0.0.53-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:14:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15435 0 None None None 2016-06-17 17:02:45 UTC

Description Justin Sherrill 2016-06-17 16:23:38 UTC
On a katello 3.0_rc8 system, in the content view, I was unable to find any puppet modules past pe_ in alphabetic order.  I synced the forge, and was trying to add stdlib to my content view, but the UI was not able to find it.

When scrolling, I saw many duplicate puppet modules displayed.

Comment 1 Justin Sherrill 2016-06-17 16:23:40 UTC
Created from redmine issue http://projects.theforeman.org/issues/15435

Comment 2 Justin Sherrill 2016-06-17 16:23:42 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 4 Bryan Kearney 2016-06-21 16:16:38 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15435 has been closed

Comment 6 jcallaha 2016-06-30 19:30:30 UTC
Verified in Satellite 6.2 Beta Snap 18.

I have no issues scrolling through all 4,675 puppet modules to stdlib and the end. Also, searching by name is much faster.

Comment 7 Tom McKay 2016-07-06 17:40:35 UTC
*** Bug 1309357 has been marked as a duplicate of this bug. ***

Comment 8 Bryan Kearney 2016-07-27 11:14:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.