Bug 1309446 - intel_do_flush_locked failed: No such file or directory
intel_do_flush_locked failed: No such file or directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
24
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 1354123 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 15:07 EST by katastrophal
Modified: 2017-03-28 19:19 EDT (History)
15 users (show)

See Also:
Fixed In Version: mesa-12.0.3-2.fc24 mesa-12.0.3-2.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-13 17:53:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description katastrophal 2016-02-17 15:07:17 EST
The update from https://bodhi.fedoraproject.org/updates/FEDORA-2016-606ca05253 breaks video playback of totem with gstreamer-vaapi. I wanted to try out the vulkan repository and loaded xorg-x11-drv-intel-2.99.917-19.20151206.fc23.

This driver defaults to DRI3 which may cause this issue. it works fine when downgraded to xorg-x11-drv-intel-2.99.917-16.20150729.fc23. Potential upstream bug:

https://bugs.freedesktop.org/show_bug.cgi?id=71759

Affected Packages:
xorg-x11-drv-intel-2.99.917-19.20151206.fc23


Any more infos needed?
Comment 1 Christian Stadelmann 2016-06-12 11:10:41 EDT
Upstream has a patch which seems to fix this issue.
Comment 2 Christian Stadelmann 2016-06-12 11:40:00 EDT
(In reply to Christian Stadelmann from comment #1)
> Upstream has a patch which seems to fix this issue.

https://bugs.freedesktop.org/show_bug.cgi?id=71759

LIBGL_DEBUG=verbose reveals that this is related to DRI3. With DRI2 it works fine. Set `LIBGL_DRI3_DISABLE=foo` to work around this issue.
Comment 3 Iiro Laiho 2016-07-10 14:14:50 EDT
*** Bug 1354123 has been marked as a duplicate of this bug. ***
Comment 4 Iiro Laiho 2016-07-10 15:01:04 EDT
This affects Fedora 24 as well and it breaks hardware acceleration in Totem's h.264 playback with rpmfusion's codecs.
Comment 5 Peque 2016-08-02 05:04:02 EDT
I can confirm it affects Fedora 24 as well. The Fedora version of this bug should be bumped (or is it better to open a new bug?).

This bug might be related as well:

  https://bugzilla.redhat.com/show_bug.cgi?id=1323398
Comment 6 Sergio Monteiro Basto 2016-08-05 19:00:44 EDT
after reading https://bugzilla.redhat.com/show_bug.cgi?id=1323398

dnf remove gstreamer1-vaapi 

fixes intel_do_flush_locked failed: No such file or directory, for me !
Comment 7 Timur Kristóf 2016-08-16 22:42:23 EDT
@Sergio That's just a workaround, not an actual fix. The problem here is that it doesn't work when gstreamer1-vaapi is installed. In other words, you can't get hardware accelerated video playback.
Comment 8 Iiro Laiho 2016-10-10 15:20:38 EDT
There's now an upstream fix submitted that is going to be in the upstream release "12.0.4".

https://bugs.freedesktop.org/show_bug.cgi?id=71759

Martin Peres wrote:

"I got the patchset reviewed by the release maintainer and he told me to CC: stable. So it should go to 12.0.4."
Comment 9 Hans de Goede 2016-10-11 09:15:08 EDT
I've started a mesa build with the 2 patches from upstream fixing this for F24+. Expect updated packages fixing this soon.
Comment 10 Fedora Update System 2016-10-13 00:52:58 EDT
mesa-12.0.3-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-472d548966
Comment 11 Fedora Update System 2016-10-13 01:53:50 EDT
mesa-12.0.3-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-62a74bf27d
Comment 12 Fedora Update System 2016-10-13 17:53:27 EDT
mesa-12.0.3-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-10-14 15:34:08 EDT
mesa-12.0.3-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Arnaldo 2017-03-23 20:51:08 EDT
Persisted with:

   xorg-x11-drv-intel-2.99.917-26.20160929.fc25.x86_64
   mesa-dri-drivers-13.0.4-2.fc25.x86_64

libGL: Using DRI2 for screen 0
libGL: OpenDriver: trying /usr/lib64/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/i965_dri.so
libGL: Using DRI2 for screen 0
intel_do_flush_locked failed: No such file or directory

Any more infos needed? TIA
Comment 15 Sergio Monteiro Basto 2017-03-28 19:19:22 EDT
(In reply to Sergio Monteiro Basto from comment #6)
> after reading https://bugzilla.redhat.com/show_bug.cgi?id=1323398
> 
> dnf remove gstreamer1-vaapi 
> 
> fixes intel_do_flush_locked failed: No such file or directory, for me !

hum btw I tested if it works, after reinstall gstreamer1-vaapi , now doesn't crash , but still not getting image of the video just sound , removing gstreamer1-vaapi again I have video in F24 ...

Note You need to log in before you can comment on or make changes to this bug.