Bug 1309552 - kernel error on drivers/dma/ioat/dca.c:342 ioat_dca_init+0x17c/0x1a0 [ioatdma]()
kernel error on drivers/dma/ioat/dca.c:342 ioat_dca_init+0x17c/0x1a0 [ioatdma]()
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
24
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 00:52 EST by Edgar Hoch
Modified: 2016-10-03 15:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:46:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg with kernel 4.7.5-200.fc24.x86_64 (90.25 KB, text/plain)
2016-10-03 15:20 EDT, Edgar Hoch
no flags Details

  None (edit)
Description Edgar Hoch 2016-02-18 00:52:37 EST
Description of problem:

After booting kernel-4.3.5-301.fc23.x86_64, journald have logged the following kernel error.

It occurs on a Supermicro server with mainboard X8DAH.

The server seems to be usable (using ssh), but I think the kernel should not produce a backtrace.


kernel: ------------[ cut here ]------------
kernel: WARNING: CPU: 6 PID: 1400 at drivers/dma/ioat/dca.c:342 ioat_dca_init+0x17c/0x1a0 [ioatdma]()
kernel: ioatdma 0000:80:16.0: APICID_TAG_MAP set incorrectly by BIOS, disabling DCA
kernel: Modules linked in: edac_core ioatdma(+) tpm_infineon lpc_ich shpchp snd_hwdep i2c_i801 acpi_cpufreq tpm_tis snd_pcm_oss snd_seq snd_seq_device snd_pcm snd_timer vboxnetadp(OE) nfsd vbo
kernel: CPU: 6 PID: 1400 Comm: systemd-udevd Tainted: G           OE   4.3.5-301.fc23.x86_64 #1
kernel: Hardware name: Supermicro X8DAH/X8DAH, BIOS 2.1        12/30/2011
kernel:  0000000000000000 00000000d0cca38e ffff8823e6067958 ffffffff813a63ef
kernel:  ffff8823e60679a0 ffff8823e6067990 ffffffff810a07d2 ffff8811ea296000
kernel:  ffff8811ea1aac10 ffff8823e9d04d00 ffffc900197f0100 0000000000000100
kernel: Call Trace:
kernel:  [<ffffffff813a63ef>] dump_stack+0x44/0x55
kernel:  [<ffffffff810a07d2>] warn_slowpath_common+0x82/0xc0
kernel:  [<ffffffff810a08e4>] warn_slowpath_fmt_taint+0x54/0x70
kernel:  [<ffffffffa0375f0c>] ioat_dca_init+0x17c/0x1a0 [ioatdma]
kernel:  [<ffffffffa0371e2e>] ioat_pci_probe+0x85e/0xdc0 [ioatdma]
kernel:  [<ffffffff8178184e>] ? _raw_spin_unlock_irqrestore+0xe/0x10
kernel:  [<ffffffff813eff35>] local_pci_probe+0x45/0xa0
kernel:  [<ffffffff813f131d>] pci_device_probe+0xfd/0x140
kernel:  [<ffffffff814d9d12>] driver_probe_device+0x222/0x480
kernel:  [<ffffffff814d9ff4>] __driver_attach+0x84/0x90
kernel:  [<ffffffff814d9f70>] ? driver_probe_device+0x480/0x480
kernel:  [<ffffffff814d77ec>] bus_for_each_dev+0x6c/0xc0
kernel:  [<ffffffff814d94ce>] driver_attach+0x1e/0x20
kernel:  [<ffffffff814d900b>] bus_add_driver+0x1eb/0x280
kernel:  [<ffffffffa0361000>] ? 0xffffffffa0361000
kernel:  [<ffffffff814da840>] driver_register+0x60/0xe0
kernel:  [<ffffffff813ef91c>] __pci_register_driver+0x4c/0x50
kernel:  [<ffffffffa036108c>] ioat_init_module+0x8c/0x1000 [ioatdma]
kernel:  [<ffffffff81002123>] do_one_initcall+0xb3/0x200
kernel:  [<ffffffff8120435e>] ? kmem_cache_alloc_trace+0x19e/0x220
kernel:  [<ffffffff811a4a27>] ? do_init_module+0x27/0x1e5
kernel:  [<ffffffff811a4a5f>] do_init_module+0x5f/0x1e5
kernel:  [<ffffffff8112554e>] load_module+0x201e/0x2630
kernel:  [<ffffffff81121a10>] ? __symbol_put+0x60/0x60
kernel:  [<ffffffff811e584c>] ? alloc_vmap_area+0x2fc/0x360
kernel:  [<ffffffff81125cae>] SyS_init_module+0x14e/0x190
kernel:  [<ffffffff81781dae>] entry_SYSCALL_64_fastpath+0x12/0x71
kernel: ---[ end trace 9c3a43c266863a7c ]---


Version-Release number of selected component (if applicable):
kernel-4.3.5-301.fc23.x86_64  (see bug 1305181)

How reproducible:
Always, it occurs after each reboot.
Comment 1 Laura Abbott 2016-09-23 15:23:47 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 2 Edgar Hoch 2016-10-03 15:20 EDT
Created attachment 1206962 [details]
Output of dmesg with kernel 4.7.5-200.fc24.x86_64

The problem still exists with kernel 4.7.5-200.fc24.x86_64.
I have attached the output of dmesg containing the backtrace with this kernel.
Comment 3 Laura Abbott 2016-10-03 15:46:05 EDT
This is warning about a BIOS bug and the change to a WARN_ON_ONCE was made deliberately  https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f3c78f8515dd4cb9e26040ebb54cf589d21137ee . A real fix would need to come from the BIOS so there isn't much the kernel can do.

Note You need to log in before you can comment on or make changes to this bug.