Bug 130975 - apm suspend on ThinkPad X24 with AC power hangs.
apm suspend on ThinkPad X24 with AC power hangs.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 135777 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 08:11 EDT by Alistair Riddoch
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:11:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alistair Riddoch 2004-08-26 08:11:41 EDT
Description of problem:

The problem occurs when suspending an IBM ThinkPad X24 using the
keyboard suspend button, or the lid. The system is booted with
acpi=off to disable ACPI and fall back to APM. Suspending with AC
power connected causes the machine to hang, whereas suspending while
the machine is on battery works fine.

Version-Release number of selected component (if applicable):

apmd-3.0.2-22
kernel-2.6.8-1.521

How reproducible:

Always.

Steps to Reproduce:
1. Start with the machine running in AC power.
2. Close the lid, or press Fn-F4 to suspend.
3.
  
Actual results:

The backlight turns off, and the machine hangs without suspending.

Expected results:

The machine should suspend.

Additional info:

ACPI suspend on the same machine also does not work, with different
symptoms which appear to be common to many systems. This kernel patch
may be of some use but I have not yet tested it:
http://bugzilla.kernel.org/show_bug.cgi?id=1415
Comment 1 Bill Nottingham 2004-08-26 13:43:36 EDT
This appears to be an interaction between the kernel and your APM bios.
Comment 2 Tim Taiwanese Liim 2004-10-27 19:44:13 EDT
I have exactly the same problem on my IBM ThinkPad T23.
- "apm -s" hangs without suspending if on AC power.
- "apm -s" works if on battery.

"apm -s" used to work on RedHat9, FC1, but stopped working
in FC2 and in FC3.  The revisions I tried are
    acpid-1.0.3-2
    kernel-2.6.9-1.643
    apmd-3.0.2-24
in fc3test3.

Judging from these bug reports,
    127845 apm suspend/resume does not work
    130975 apm suspend on ThinkPad X24 with AC power hangs.
    133105 apm/power-management broken on Thinkpad 600E
It seemed the problem is across all IBM notebooks.


I agree with Bill that it is "an interaction between the kernel
and your APM bios," although it left me as clueless as without
Bill's comment.  

What interaction is it that it worked in FC1 but broken in FC2 
and later?  How can we help you debug, Bill?
Comment 3 Ian Collier 2005-01-20 06:11:27 EST
Similar behaviour here on a ThinkPad T22 with FC2 and kernels up to and
including 2.6.9-1.6_FC2 [I may have missed some updates after that].
In particular...

If I remove both the wireless ethernet CardBus adaptor and the AC
power, APM suspend works perfectly in almost all cases.

If the power and network card remain connected, documented ThinkPad
behaviour is that when you close the lid it gives a high-low beep and
continues running without suspending.  This is perfectly normal.

If I succeed in suspending the machine but didn't remove the wireless
card then the machine seems to lose all ability to read from the hard
disk when it wakes up and has to be rebooted.  This isn't within the
scope of this bug report but I mention it for completeness.

If I remove the wireless card but not the AC power, typing "apm -s"
results in the same high-low beep as mentioned above; the machine
stays in a powered-up state but stops running.  If I resume the
machine immediately then it usually (though not always) comes back to
life and runs normally.  However, the one time I left the machine
overnight in this state it was dead when I tried to wake it up.

Kernel 2.6.10-1.9_FC2 appears to fix all the above issues when tested
with short-duration sleeps but I have a 100% crash record for sleeps
of more than a few minutes with this kernel - this looks like
bug 144415.
Comment 4 Tim Taiwanese Liim 2005-01-27 23:19:37 EST
*** Bug 135777 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2005-04-16 01:11:21 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 6 Alistair Riddoch 2005-04-16 07:50:27 EDT
This problem appears to have been fixed at some point in the FC3 kernels.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.