Bug 13098 - Rpm 4 cannot be installed with rpm 3!
Rpm 4 cannot be installed with rpm 3!
Status: CLOSED DUPLICATE of bug 12401
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-06-27 04:54 EDT by ted
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-07-05 08:03:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description ted 2000-06-27 04:54:52 EDT

I was willing to try some of the packages now available on rawhide. The
rawhide packages I was interested in were packed with RPM 4 and cannot be
installed using RPM 3 (I have a RH 6.2 box). I decided to download the rpm
4 packages, to install them and then to install the packages I am
interested in...

What has been my surprise and my disappointment discovering that RPM 3
cannot install RPM 4. This means that only RPM 4 can install RPM 4. This is
a little bit kafkaian...

Can the RPM 4 package be packed by using RPM 3? This would ease the


PS: BTW, can't RH create a directory containing only the .spec files used
to generate the packages. I know they can be extracted from the .src.rpm
but this would be much easier and faster to download directly the ascii
.spec (to compile RPM 4 and generate my own packages using RPM 3 for

I have the same problem with lesstif. Now RH only provides the Lesstif
motif libraries 1.2 instead of 1.2 and 2.0 as before. I would like to
generate the complete set by using the last up to date .spec file from RH
instead of the one provided by lesstif.org
Comment 1 Jeff Johnson 2000-07-05 08:03:42 EDT
Try rpm-3.0.5 from ftp://ftp.rpm.org/pub/rpm/test.

Download the src rpm if you want spec files. There's little utility in creating
an additional directory where spec files can be downloaded because that's what
src rpm's are for. Creating and maintaining a directory of spec files
independently of the src.rpm's, particularly for older packages like lesstif,
with various styles of packaging, versions of rpm, FHS changes, patch of the day
etc, cannot be justified by the bandwidth savings alone.
Comment 2 Jeff Johnson 2000-07-10 16:06:46 EDT

*** This bug has been marked as a duplicate of 12401 ***

Note You need to log in before you can comment on or make changes to this bug.