Bug 1309820 - when not using network isolation, after an update from GA to latest release the apis try to reach the old public_virtual_ip
when not using network isolation, after an update from GA to latest release t...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: async
: 7.0 (Kilo)
Assigned To: Jiri Stransky
Alexander Chuzhoy
: Automation, TestOnly
Depends On: 1290826 1291845 1309815
Blocks: 1291844
  Show dependency treegraph
 
Reported: 2016-02-18 13:49 EST by Scott Lewis
Modified: 2016-03-09 15:02 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290826
Environment:
Last Closed: 2016-03-09 15:02:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 232101 None None None 2016-02-18 13:49 EST
OpenStack gerrit 257520 None None None 2016-02-18 13:49 EST
OpenStack gerrit 257856 None None None 2016-02-18 13:49 EST

  None (edit)
Comment 7 mathieu bultel 2016-02-23 04:24:42 EST
Same for me :

$ rpm -qa | grep tripleo-heat
openstack-tripleo-heat-templates-0.8.6-121.el7ost.noarch


$ ls -alh /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-publicvip-on-ctlplane.yaml
-rw-r--r--. 1 root root 104 Feb 16 14:28 /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-publicvip-on-ctlplane.yaml
Comment 10 Alexander Chuzhoy 2016-02-23 19:01:21 EST
Verified:
Environment:
openstack-tripleo-heat-templates-0.8.6-122.el7ost.noarch


Update of 7.0 -> 7.3 with the passed /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-publicvip-on-ctlplane.yaml file completed successfully.


the control_virtual_ip and public_virtual_ip addresses are the same before and after the update which is what the BZ was about
Comment 12 errata-xmlrpc 2016-03-09 15:02:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0424.html

Note You need to log in before you can comment on or make changes to this bug.