Bug 1309999 - Data Tiering:Don't allow a detach-tier commit if detach-tier start has failed to complete
Summary: Data Tiering:Don't allow a detach-tier commit if detach-tier start has failed...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1236067
Blocks: 1314617
TreeView+ depends on / blocked
 
Reported: 2016-02-19 08:15 UTC by hari gowtham
Modified: 2016-06-16 13:57 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1236067
: 1314617 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:57:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-02-19 08:16:42 UTC
REVIEW: http://review.gluster.org/13474 (Tier: making detach start fail when brick on hot tier is down) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Vijay Bellur 2016-02-19 12:51:42 UTC
REVIEW: http://review.gluster.org/13474 (Tier: making detach start fail when brick on hot tier is down) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 3 Vijay Bellur 2016-02-26 06:33:00 UTC
REVIEW: http://review.gluster.org/13474 (Tier: making detach start fail when brick on hot tier is down) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 4 Vijay Bellur 2016-02-29 05:33:20 UTC
REVIEW: http://review.gluster.org/13474 (Tier: making detach start fail when brick on hot tier is down) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 5 Vijay Bellur 2016-03-01 13:00:13 UTC
REVIEW: http://review.gluster.org/13474 (Tier: making detach start fail when brick on hot tier is down) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 6 Vijay Bellur 2016-03-03 05:53:07 UTC
REVIEW: http://review.gluster.org/13474 (Tier: making detach start fail when brick on hot tier is down) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 7 Vijay Bellur 2016-03-03 11:51:18 UTC
COMMIT: http://review.gluster.org/13474 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 133441436875416258bdc1272db91fab73a7065c
Author: hari <hgowtham@redhat.com>
Date:   Fri Feb 19 13:43:48 2016 +0530

    Tier: making detach start fail when brick on hot tier is down
    
    Currently detach tier start happens even when a hot brick is down
    this might lead to data loss.
    
    This patch prevents the detach tier start from being executed
    successfully if a brick in hot tier is down
    
    Change-Id: I3b6047a44bd01b8a6887d41f799f64de6bf075ef
    BUG: 1309999
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13474
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 8 Mike McCune 2016-03-28 22:40:27 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 9 Niels de Vos 2016-06-16 13:57:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.