Bug 1314617 - Data Tiering:Don't allow a detach-tier commit if detach-tier start has failed to complete
Data Tiering:Don't allow a detach-tier commit if detach-tier start has failed...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.8
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1236067 1309999
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 00:30 EST by hari gowtham
Modified: 2016-04-19 03:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1309999
Environment:
Last Closed: 2016-04-19 03:21:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 hari gowtham 2016-03-04 00:35:02 EST
RCA: Checking whether the brick is down or not is done for detach tier. 
This patch will do it
Comment 2 Vijay Bellur 2016-03-04 00:36:32 EST
REVIEW: http://review.gluster.org/13602 (Tier: making detach start fail when brick on hot tier is down) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2016-03-08 10:51:05 EST
COMMIT: http://review.gluster.org/13602 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 67704349dff995436ed4db8c8da55648e40c7388
Author: hari <hgowtham@redhat.com>
Date:   Fri Feb 19 13:43:48 2016 +0530

    Tier: making detach start fail when brick on hot tier is down
    
            backport of : http://review.gluster.org/#/c/13474/6
    
    Currently detach tier start happens even when a hot brick is down
    this might lead to data loss.
    
    This patch prevents the detach tier start from being executed
    successfully if a brick in hot tier is down
    
    >Change-Id: I3b6047a44bd01b8a6887d41f799f64de6bf075ef
    >BUG: 1309999
    >Signed-off-by: hari <hgowtham@redhat.com>
    
    Change-Id: Ica0ae72f8e30156090be43e428545d684bdea36b
    BUG: 1314617
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13602
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Kaushal 2016-04-19 03:21:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.