Bug 1310032 - cannot close left menu
Summary: cannot close left menu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
: 1313815 (view as bug list)
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-02-19 09:42 UTC by Martin Kudlej
Modified: 2016-08-23 19:47 UTC (History)
6 users (show)

Fixed In Version: rhscon-ui-0.0.51-1.el7scon.noarch
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:47:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Martin Kudlej 2016-02-19 09:42:20 UTC
Description of problem:
It is not possible to close left menu anymore. I don't see any error in Javascript Console. User cannot do that in Firefox and Google Chrome.


Version-Release number of selected component (if applicable):
rhscon-core-0.0.8-4.el7.x86_64
rhscon-ceph-0.0.6-4.el7.x86_64
rhscon-ui-0.0.14-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. try to click on icon in top left 

Actual results:
menu does not close/open

Expected results:
after click on icon in top left corner menu will close/open

Comment 1 Nishanth Thomas 2016-06-21 05:49:37 UTC
As discussed in the bug scrub meeting this might not get implemented in 2.0. As long as the menu gets closed once the mouse is out of focus or click on the outer canvas, the behaviour would be fine. Please check and get back, if things are fine I will close this bug

Comment 2 Sharmilla Abhilash 2016-06-23 12:00:49 UTC
*** Bug 1313815 has been marked as a duplicate of this bug. ***

Comment 3 Martin Kudlej 2016-07-04 13:03:43 UTC
It is already possible to close left menu by icon "=" in left upper corner. But I see issue in closing left submenu. It doesn't work properly in 
Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
and
Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Reproducer:
1. Click on "Admin"
2. Click anywhere else on page -> submenu doesn't close

Comment 5 Martin Kudlej 2016-07-27 13:09:20 UTC
Tested with 
ceph-ansible-1.0.5-31.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.36-1.el7scon.x86_64
rhscon-core-0.0.36-1.el7scon.x86_64
rhscon-core-selinux-0.0.36-1.el7scon.noarch
rhscon-ui-0.0.50-1.el7scon.noarch
and it is possible to close left menu by "=" button in left upper menu.
Issue with submenu is still there.
Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0

Comment 6 Martin Kudlej 2016-07-28 12:42:52 UTC
Moving to verified state according discussion. In case of other issues new bug will be filed.

Comment 8 errata-xmlrpc 2016-08-23 19:47:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.