Bug 1313815 - Sub-menus auto hide
Sub-menus auto hide
Status: CLOSED DUPLICATE of bug 1310032
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity medium
: ---
: 2
Assigned To: Karnan
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 07:03 EST by Lubos Trilety
Modified: 2016-06-23 08:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 08:00:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sub-menu remains open (32.36 KB, image/png)
2016-03-02 07:03 EST, Lubos Trilety
no flags Details
wider basic menu (25.78 KB, image/png)
2016-03-02 07:05 EST, Lubos Trilety
no flags Details

  None (edit)
Description Lubos Trilety 2016-03-02 07:03:50 EST
Created attachment 1132280 [details]
sub-menu remains open

Description of problem:
Several items have some sub-menu, which in normal case hides when it's not using. With that the main page is aligned to the basic menu normal wide and sub-menu is shown over this main page. But after reload of the page this auto-hide functionality stops to work. And in some cases the basic menu is wide as the normal menu with sub-menu together.

Version-Release number of selected component (if applicable):
rhscon-ui-0.0.19-1.el7.noarch
rhscon-ceph-0.0.6-10.el7.x86_64
rhscon-core-0.0.8-9.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Log to the UI
2. Reload any page
3. Go to some sub-menu (e.g. Admin) and choose some item there (e.g. Events)

Actual results:
Sub-menu remains open and the main page wide is lesser than normal. If the 'Admin' item was clicked before choosing 'Events' sub-item sub-menu was not shown but the menu is wide as menu + sub-menu.

Expected results:
Hiding is working properly.

Additional info:
Comment 1 Lubos Trilety 2016-03-02 07:05 EST
Created attachment 1132282 [details]
wider basic menu
Comment 5 Sharmilla Abhilash 2016-06-23 08:00:49 EDT

*** This bug has been marked as a duplicate of bug 1310032 ***

Note You need to log in before you can comment on or make changes to this bug.