Bug 1310070 - RFE: pavucontrol for EL7
RFE: pavucontrol for EL7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 1342325 (view as bug list)
Depends On:
Blocks: 1340501
  Show dependency treegraph
 
Reported: 2016-02-19 06:34 EST by Todd
Modified: 2016-11-29 20:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-29 20:22:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd 2016-02-19 06:34:45 EST
Hi All,

Request for Enhancement:

Scientific Linux 7.2

Since the last "yum upgrade", VLC (from nux) was completely quiet.  No sound at all.  Everything else has sound but not VLC.  I tried both nux's 2.2 and 2.1.  VLC is set to "defaults" and is not muted.  I have uninstalled and reinstall several times.  No joy.

It took me a bit, but I fixed it.

I had to install pavucontrol-3.0-1.fc22.x86_64.rpm.   Open pavucontrol.  Then go to "playback", start VLC playing (which shows in panel), then change VLC's playback device to "Built-in Analog Analog Stereo" from "HDMI".  Did the trick.

Apparently every audio program can choose its playback device.  VLC was stuck on HDMI.  (I did try to change this in Preferences, Audio.)  Bummer.

Now I have a cool pavucontrol for pulse audio.

Would you please consider porting pavucontrol from Fedora to EPEL?

Many thanks,

-T
Comment 1 Rex Dieter 2016-05-06 09:30:00 EDT
triaging to fedora/pavucontrol
Comment 2 Mukundan Ragavan 2016-06-04 09:45:33 EDT
*** Bug 1342325 has been marked as a duplicate of this bug. ***
Comment 3 Mukundan Ragavan 2016-06-04 09:46:23 EDT
I am willing to co-maintain the package in EPEL-7.
Comment 4 Thomas Huth 2016-11-29 01:45:36 EST
Package is now available in EPEL, so I think you can close this bug now.
Comment 5 Todd 2016-11-29 01:49:57 EST
(In reply to Thomas Huth from comment #4)
> Package is now available in EPEL, so I think you can close this bug now.

I am not seeing that.  I am only seeing it in NUX.  So not fix quite yet.


# cat /etc/redhat-release
Scientific Linux release 7.2 (Nitrogen)

# yum --enablerepo=epel* whatprovides pavucontrol

pavucontrol-3.0-5.el7.nux.x86_64 : Volume control for PulseAudio
Repo        : nux-dextop

pavucontrol-3.0-5.el7.nux.x86_64 : Volume control for PulseAudio
Repo        : @nux-dextop
Comment 6 Thomas Huth 2016-11-29 02:10:16 EST
Uh, right, seems like I somehow mixed that up, it's not in EPEL, sorry for the confusion!
Comment 7 Mukundan Ragavan 2016-11-29 20:22:09 EST
It's not in epel but in RHEL server repo.

From https://bugzilla.redhat.com/show_bug.cgi?id=1340501#c3

root @ hobbiton ~# rpm -qi pavucontrol
Name        : pavucontrol
Version     : 3.0
Release     : 5.el7
Architecture: x86_64

<snip>

Source RPM  : pavucontrol-3.0-5.el7.src.rpm
Build Date  : Mon 23 May 2016 10:58:20 AM EDT
Build Host  : x86-030.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.

<snip>


root @ hobbiton ~# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)

Note You need to log in before you can comment on or make changes to this bug.