Bug 1340501 - xfce4-pulseaudio-plugin does not find pavucontrol
Summary: xfce4-pulseaudio-plugin does not find pavucontrol
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xfce4-pulseaudio-plugin
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1310070
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-27 14:57 UTC by Thomas Huth
Modified: 2016-11-29 06:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-29 01:38:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1342325 None None None Never

Internal Links: 1342325

Description Thomas Huth 2016-05-27 14:57:47 UTC
Description of problem:
One of the recent xfce4 updates seems to have replaced the xfce4-mixer plugin on my system with xfce-pulseaudio-plugin. So I've added this new plugin to my XFCE panel, but with this plugin I can now not access the full audio mixer dialog anymore.

Version-Release number of selected component (if applicable):
xfce4-pulseaudio-plugin-0.2.4-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Click on the speaker icon (i.e. the xfce-pulseaudio-plugin) in the panel 
2. Select the "Audio mixer..:" menu entry

Actual results:
An error dialog shows up, saying:
  Failed to execute command "pavucontrol".
  Failed to execute child process "pavucontrol" (No such file or directory)

Expected results:
Audio mixer dialog shows up instead of the error message.

Additional info:
I didn't see any RPMs in EPEL which provide a "pavucontrol" binary, "yum whatprovides pavucontrol" says "No matches found" ... is there a way to get this binary with EPEL?

Comment 1 Mukundan Ragavan 2016-05-28 00:47:51 UTC
Yes. That's because, as far as I know, there is no pavucontrol in EL-7 ... :(

I have been meaning to file a bug report requesting an EPEL-7 package for pavucontrol but have not had the chance yet .. If you are willing, please file one requesting el-7 branch.

If not, I will do it (possibly) next week.

Comment 2 bw.bugzilla 2016-11-29 00:13:13 UTC
The problem is simply that the pavucontrol package from epel provides pavucontrol-qt, not pavucontrol. Linking pavucontrol-qt to pavucontrol in /usr/bin bypasses the problem as a temporary resolution.

Comment 3 Mukundan Ragavan 2016-11-29 00:51:53 UTC
Actually, this should probably be closed now that we are at RHEL 7.3

root @ hobbiton ~# rpm -qi pavucontrol
Name        : pavucontrol
Version     : 3.0
Release     : 5.el7
Architecture: x86_64

<snip>

Source RPM  : pavucontrol-3.0-5.el7.src.rpm
Build Date  : Mon 23 May 2016 10:58:20 AM EDT
Build Host  : x86-030.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.

<snip>


root @ hobbiton ~# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)

Comment 4 Thomas Huth 2016-11-29 06:44:21 UTC
I just installed the package, and it works fine, thanks a lot for that!


Note You need to log in before you can comment on or make changes to this bug.