Bug 1310114 - [RFE] Adding Ceilometer event support for Openstack providers
[RFE] Adding Ceilometer event support for Openstack providers
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.4
Assigned To: Tzu-Mainn Chen
Ronnie Rasouli
openstack
: FutureFeature, ZStream
Depends On:
Blocks: 1326509
  Show dependency treegraph
 
Reported: 2016-02-19 08:50 EST by John Prause
Modified: 2016-05-31 09:40 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.4.0
Doc Type: Enhancement
Doc Text:
This Red Hat CloudForms update adds the ability to specify the AMQP server IP address for OpenStack providers. As a result, when deploying an undercloud with SSL enabled, the Keystone endpoints are set on a different IP address than the address RabbitMQ uses to bind.
Story Points: ---
Clone Of: 1296146
: 1326509 (view as bug list)
Environment:
Last Closed: 2016-05-31 09:40:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Marius Cornea 2016-05-16 04:55:00 EDT
I wasn't able to get the events from an Openstack infra provider showing up in the UI. evm.log shows the following message continuously:

INFO -- : Reseting Openstack Ceilometer connection after could not obtain a database connection within 5.000 seconds (waited 5.000 seconds).

After adjusting the pool in config/database.yml I hit BZ#1336336 which seems to be caused by a wrong version of fog.
Comment 8 Ronnie Rasouli 2016-05-26 08:03:42 EDT
I was able to verify.
Configured the openstack director with Ceilometer support, e.g. configured wrong credentials in AMQP 
grep store_events undercloud.conf 
store_events = true
I can see in nodes utilizations events
Comment 10 errata-xmlrpc 2016-05-31 09:40:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1101

Note You need to log in before you can comment on or make changes to this bug.