Bug 131014 - k3b detects CD writer as reader
k3b detects CD writer as reader
Status: CLOSED DUPLICATE of bug 130576
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 13:23 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
k3b configuration dialog showing writer (70.26 KB, image/jpeg)
2004-08-26 13:24 EDT, Ralf Ertzinger
no flags Details

  None (edit)
Description Ralf Ertzinger 2004-08-26 13:23:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
k3b falsely detects a SCSI CD writer as a reader device (and thus
refuses to write to it, naturally).

This is the same machine as in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=130864, it has an
ATAPI DVD writer and a SCSI CD writer. The ATAPI device is correctly
detected as a writer by k3b (but not usable due to the cdrecord issues
mentioned in bug 130864), the SCSI CD writer is detected as a reader
device (although it works fine from the command line using cdrecord).
Kind of annoying :)

Attached is a screenshot from k3b configuration dialog showing the CD
writer. Although not visible on the screenshot this shows the "Reader"
device tree. Please note that k3b (correctly) shows that the device is
capable of writing CD/RW, but treats it as a reader nontheless.

Version-Release number of selected component (if applicable):
k3b-0.11.12-2

How reproducible:
Always

Steps to Reproduce:
1. Start k3b with a SCSI CD writer
2. Look in the configuration dialog where the device is listed
3.
    

Actual Results:  Device is listed as a reader

Expected Results:  Device is listed as a writer

Additional info:
Comment 1 Ralf Ertzinger 2004-08-26 13:24:52 EDT
Created attachment 103129 [details]
k3b configuration dialog showing writer
Comment 2 Gerry Tool 2004-08-26 21:33:54 EDT
Similar problem here with two ATAPI writers in both FC2 and FC3T1.  A
Samsung CD-R/RW SW-240B and a Plextor DVDR PX-712A.  The Samsung is
listed as a Reader, but shows burning capabilities for CD/RWs but not CDs.

The Plextor is listed as a writer, but says no for "Writes CDs" and
"Writes DVD+R(W)s", and says yes for "Writes CD/RWs", "Reads DVDs" and
"Writes DVD-R(W)s"  It is capable of all these writes.

An older K3b I use in FC1 lists both devices as writers and writes CDs
with both of these devices.
Comment 3 Ralf Ertzinger 2004-08-27 08:45:01 EDT
I think "Writes CDs: no" is correct for all writing devices available
to normal customers :)

I checked my DVD writers entries, however, and it also states "Writes
DVD+R(W): no", which is incorrect.
Comment 4 Harald Hoyer 2004-08-27 09:19:16 EDT
could you please provide the ownership and permissions of the device
files?
e.g. 
# ls -l /dev/hdc 
or 
# ls -l /dev/scd0
Comment 5 Ralf Ertzinger 2004-08-27 09:51:04 EDT
File is mode 600, owned by the user currently logged in (as set by
/etc/security/console.perms)
Comment 6 Bill Nottingham 2004-08-27 12:11:39 EDT
Just checking - does the output change if you run k3b as root?
Comment 7 Harald Hoyer 2004-08-27 12:15:49 EDT
newer kernels seem to be very restrictive about certain SCSI commands
from non-root users, I think..
Comment 8 Ralf Ertzinger 2004-08-27 12:49:27 EDT
When running k3b as root (tested by logging into X as normal user,
opening an xterm, doing "su" and then k3b) shows every SCSI drive in
the system twice in the configuration dialog, but the SCSI writer is
correctly listed as a writing device (albeit twice)
Comment 9 Brian Millett 2004-08-27 13:32:36 EDT
Same problem here.  Read from http://k3b.plainblack.com/index.pl/news2
the interesting information: (yes, booting a 2.6.7-1.517 kernel fixed it)

Do not use Kernel 2.6.8

A patch that was introduced into the kernel shortly before the 2.6.8
release makes K3b and also the dvd+rw-tools unusable on Linux (unless
run as root but that is not recommended). The very important GET
CONFIGURATION MMC command is rejected by the kernel for reasons I
cannot see and writing commands like MODE SELECT also fail (K3b cannot
detect CD writers without it) even when the device is opened O_RDWR.
Until this issue has been solved I strongly recommend to stick to
kernel version 2.6.7.

Update: The kernel guys are currently fixing the problem so the next
kernel release should work again. :)

Update 2: The problem is NOT fixed in 2.6.8.1

Update 3: Be aware that kernel 2.6.8 also contains the memory leak
which makes it impossible to write audio cds, even as root.
Comment 10 Brian Millett 2004-08-28 12:19:42 EDT
well, kernel 2.6.8-1.532 did not fix it.  Still on 2.6.7-1.517.
Comment 11 Harald Hoyer 2004-08-30 04:19:14 EDT

*** This bug has been marked as a duplicate of 130576 ***
Comment 12 Mark Smulders 2004-10-20 07:14:55 EDT
2.6.9 fixes the problem
Comment 13 Red Hat Bugzilla 2006-02-21 14:05:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.