Bug 1310252 - kernel-4.4.2-300.fc23.x86_64 causes screen flickering
Summary: kernel-4.4.2-300.fc23.x86_64 causes screen flickering
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1316538 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-19 21:07 UTC by H.J. Lu
Modified: 2016-03-12 02:26 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-12 02:26:51 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 93892 0 None None None 2016-02-26 16:15:48 UTC
FreeDesktop.org 94144 0 None None None 2016-02-26 16:15:00 UTC

Description H.J. Lu 2016-02-19 21:07:51 UTC
I have

[hjl@gnu-6 ~]$ lspci
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H87 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
03:00.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 41)
[hjl@gnu-6 ~]$ 

kernel-4.4.2-300.fc23.x86_64 causes screen flickering for less than 1 second
from time to time, especially when moving cursor over gnome-terminal
3.18.2-1.fc23.x86_64.  kernel-4.3.5-300 kernel has no problems.

Comment 1 H.J. Lu 2016-02-23 14:14:19 UTC
It happens on both Haswell and Skylake machines.  Thee are subtle flickers
of bottom screen area, perceivable during UI or related workload instances.

Comment 2 Matthias Runge 2016-02-24 07:23:39 UTC
For me, I have screen blanks for 1-3 seconds on both screens attached to a docking station (T450s), blanks occur independend from each other, nothing is found in the logs here.

Comment 3 H.J. Lu 2016-02-26 21:11:41 UTC
This seems a dup of

https://bugs.freedesktop.org/show_bug.cgi?id=93892

and fixed by

From e2e407dc093f530b771ee8bf8fe1be41e3cea8b3 Mon Sep 17 00:00:00 2001
From: Matt Roper <matthew.d.roper@intel.com>
Date: Mon, 8 Feb 2016 11:05:28 -0800
Subject: [PATCH] drm/i915: Pretend cursor is always on for ILK-style WM
 calculations (v2)

Due to our lack of two-step watermark programming, our driver has
historically pretended that the cursor plane is always on for the
purpose of watermark calculations; this helps avoid serious flickering
when the cursor turns off/on (e.g., when the user moves the mouse
pointer to a different screen).  That workaround was accidentally
dropped as we started working toward atomic watermark updates.  Since we
still aren't quite there yet with two-stage updates, we need to
resurrect the workaround and treat the cursor as always active.

v2: Tweak cursor width calculations slightly to more closely match the
    logic we used before the atomic overhaul began.  (Ville)

Comment 4 Laura Abbott 2016-02-26 21:18:12 UTC
The last comment there said it wasn't actually fixed so I didn't pull it into 4.4.3. Did anyone else confirm if it fixed the flickering?

Comment 5 Fedora Update System 2016-03-05 23:19:47 UTC
kernel-4.4.4-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-746bb5851d

Comment 6 Fedora Update System 2016-03-05 23:22:37 UTC
kernel-4.4.4-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6cfaff4b1

Comment 7 Fedora Update System 2016-03-07 00:22:53 UTC
kernel-4.4.4-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-746bb5851d

Comment 8 Fedora Update System 2016-03-07 00:26:49 UTC
kernel-4.4.4-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6cfaff4b1

Comment 9 Laura Abbott 2016-03-10 17:29:50 UTC
*** Bug 1316538 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2016-03-11 13:26:40 UTC
kernel-4.4.4-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-03-12 00:51:03 UTC
kernel-4.4.4-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.