Bug 131042 - rpmbuild -bp changes uncompression behaviour under --force
rpmbuild -bp changes uncompression behaviour under --force
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 17:00 EDT by James Antill
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2004-08-26 17:00:37 EDT
Description of problem:
% sudo rpmbuild -bp --nodeps --force
/usr/src/redhat/SPECS/control-center.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.2094
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf control-center-2.2.0.1
+ tar -xf /usr/src/redhat/SOURCES/control-center-2.2.0.1.tar.bz2
tar: Archive contains obsolescent base-64 headers
% sudo rpmbuild -bp --nodeps /usr/src/redhat/SPECS/control-center.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.64274
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf control-center-2.2.0.1
+ /usr/bin/bzip2 -dc
/usr/src/redhat/SOURCES/control-center-2.2.0.1.tar.bz2
+ tar -xf -

...so specifying --force changes whether bzip2 is performed.

Version-Release number of selected component (if applicable):

rpm-build-4.2.2-0.14

How reproducible:

 Always
Comment 1 Jeff Johnson 2004-08-26 20:15:08 EDT
Perhaps. Removing --force as rpmbuild option will be the fix
somewhen, as it does not do anything useful or important.

You can easily achieve that "fix" right now by
not using --force ;-)
Comment 2 James Antill 2004-08-26 22:36:29 EDT
 I always loved your comments Jeff :)

 But, although I hesitate to admit it, removing --force would probably
fix this for me ... because I always assume --force does what --nodeps
does, it doesn't work and so then I add --nodeps ... so if it didn't
exist I'd have changed it instead :) :).

 Anyway, yeh I stopped doing what hurt doctor :) ... feel free to
close, if you want.

Note You need to log in before you can comment on or make changes to this bug.