This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1310450 - The CD list in 'change CD' console menu still available after detaching ISO domain
The CD list in 'change CD' console menu still available after detaching ISO ...
Status: CLOSED DUPLICATE of bug 1313371
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: pre-dev-freeze
: ---
Assigned To: Christophe Fergeau
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 13:09 EST by Shira Maximov
Modified: 2016-03-23 08:48 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313371 1313376 (view as bug list)
Environment:
Last Closed: 2016-03-23 08:48:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (3.43 MB, text/plain)
2016-02-21 13:09 EST, Shira Maximov
no flags Details

  None (edit)
Description Shira Maximov 2016-02-21 13:09:46 EST
Created attachment 1129071 [details]
engine log

Description of problem:
The CD list in 'change CD' menu still appears after detaching ISO domain 

Version-Release number of selected component (if applicable):
The CDs in 'change CD' console menu still appears after detaching iso domain 

How reproducible:
100%

Steps to Reproduce:
1. attach storage domain 
2. connect to admin portal (with fqdn)
3. open Vm console (make sure you have permission on the VM) see the available CDs in 'change CD' 
4. detach ISO domain
5. open console again and see that the CD list is still available.

Actual results:
the CD list is still available.

Expected results:
the CD list should not be available.

Additional info:
Comment 1 Tomas Jelinek 2016-02-22 03:55:13 EST
@Christophe: oVirt's REST API returns the list of CDs of the domain also when the domain is not attached. But when you get the ".../ovirt-engine/api/storagedomains/<storage id>" it will return:
"
...
<status>
<state>unattached</state>
</status>
...
"

Do you think you could do a check on remote-viewer side and show the menu only when the status of the storage domain is "active"?
Comment 2 Christophe Fergeau 2016-02-29 12:07:23 EST
(In reply to Tomas Jelinek from comment #1)
> 
> Do you think you could do a check on remote-viewer side and show the menu
> only when the status of the storage domain is "active"?

Sure, that's a minor change (bug fix) on the remote-viewer side. Moving the bug.
Comment 3 Christophe Fergeau 2016-03-01 08:41:13 EST
Fixed by https://www.redhat.com/archives/virt-tools-list/2016-March/msg00000.html
Comment 5 Christophe Fergeau 2016-03-23 08:48:18 EDT
Ah if you don't want to keep it in RHEV, that makes it a duplicate of #1313371

*** This bug has been marked as a duplicate of bug 1313371 ***

Note You need to log in before you can comment on or make changes to this bug.