Bug 1313371 - The CD list in 'change CD' console menu still available after detaching ISO domain
The CD list in 'change CD' console menu still available after detaching ISO ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
SPICE QE bug list
:
: 1310450 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 08:43 EST by Christophe Fergeau
Modified: 2016-11-03 21:15 EDT (History)
20 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1310450
Environment:
Last Closed: 2016-11-03 21:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2016-03-01 08:43:16 EST
+++ This bug was initially created as a clone of Bug #1310450 +++

Description of problem:
The CD list in 'change CD' menu still appears after detaching ISO domain 

Version-Release number of selected component (if applicable):
The CDs in 'change CD' console menu still appears after detaching iso domain 

How reproducible:
100%

Steps to Reproduce:
1. attach storage domain 
2. connect to admin portal (with fqdn)
3. open Vm console (make sure you have permission on the VM) see the available CDs in 'change CD' 
4. detach ISO domain
5. open console again and see that the CD list is still available.

Actual results:
the CD list is still available.

Expected results:
the CD list should not be available.

Additional info:

--- Additional comment from Tomas Jelinek on 2016-02-22 03:55:13 EST ---

@Christophe: oVirt's REST API returns the list of CDs of the domain also when the domain is not attached. But when you get the ".../ovirt-engine/api/storagedomains/<storage id>" it will return:
"
...
<status>
<state>unattached</state>
</status>
...
"

Do you think you could do a check on remote-viewer side and show the menu only when the status of the storage domain is "active"?

--- Additional comment from Christophe Fergeau on 2016-02-29 12:07:23 EST ---

(In reply to Tomas Jelinek from comment #1)
> 
> Do you think you could do a check on remote-viewer side and show the menu
> only when the status of the storage domain is "active"?

Sure, that's a minor change (bug fix) on the remote-viewer side. Moving the bug.

--- Additional comment from Christophe Fergeau on 2016-03-01 08:41:13 EST ---

Fixed by https://www.redhat.com/archives/virt-tools-list/2016-March/msg00000.html
Comment 2 Fabiano Fidêncio 2016-03-17 11:34:47 EDT
The commit in question:
0ea2a674b8a7fd51dc1a115c646fe6ff82da3e39
Comment 4 Christophe Fergeau 2016-03-23 08:48:18 EDT
*** Bug 1310450 has been marked as a duplicate of this bug. ***
Comment 5 xiaodwan 2016-04-19 01:01:13 EDT
I can reproduce it with virt-viewer-2.0-6.el7.x86_64.

# rpm -q virt-viewer
virt-viewer-2.0-6.el7.x86_64

Steps:
1. Make sure there is an ISO domain on rhevm. If not, please create one and added some iso files.
2. Configure permission for VM.
   2.1 Login admin portal of RHEVM as admin, Click "Virtual Machine" tabs, Select a guest and then Guest detail info will be displayed below the page. 
   2.2 Click "Permissions"->Click "add"->Type "admin" and click "Go"
   2.3 Click the checkbox and select the admin user and choose "UserRole" for Role to Assing.
3. Download ca.crt file and then do "trust anchor ca.crt" as root

   # wget -k https://dell-op780-05.qe.lab.eng.nay.redhat.com/ca.crt

   In RHEL7 host: 
   # trust anchor ca.crt
   In RHEL6 host:
   # cat ca.crt >>/etc/pki/tls/certs/ca-bundle.crt
   # update-ca-trust
4. Download the console.vv file of the vm and then run "remote-viewer console.vv" or just click and console icon and open the vm directory on rhevm web portal. The "change cd" menu should be seen.
5. Detach the iso domain.
   5.1 Click the "Storage" tab on rhevm and select the iso domain
   5.2 Click the "Data Center" tab of the iso domain.
   5.3 Click "Maintenance" and then Click "Detach".
6. Download the console.vv file of the vm and then run "remote-viewer console.vv" or just click and console icon and open the vm directory on rhevm web portal. 

Actual Result:
The "change cd" menu still can be seen.

Then updated virt-viewer to latest virt-viewer-2.0-7.el7.x86_64 and then open the vm again. The "change cd" can't be seen any more.
At last, Attach the iso domain again and open the vm, the "change cd" can be seen.


So move the bug from ON_QA to VERIFIED.
Comment 7 errata-xmlrpc 2016-11-03 21:15:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.