Bug 1310502 - Audacity fails to start with symbol lookup error
Audacity fails to start with symbol lookup error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
24
x86_64 Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: David Timms
Fedora Extras Quality Assurance
: Reopened
: 1311309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 22:36 EST by Devin Henderson
Modified: 2016-04-02 11:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: audacity-2.1.2-3.fc23 audacity-2.1.2-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-02 11:54:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devin Henderson 2016-02-21 22:36:36 EST
Description of problem:

Audacity fails to start


Version-Release number of selected component (if applicable):

audacity.x86_64    2.1.2-0.7.rc1.fc23

How reproducible:


Steps to Reproduce:
1. Run 'audacity' from command line

Actual results:
"audacity: symbol lookup error: audacity: undefined symbol: _ZN10soundtouch10SoundTouch14setTempoChangeEf"

Expected results:
Audacity opens
Comment 1 Glen Kaukola 2016-02-22 00:23:57 EST
I'm only seeing the string _ZN10soundtouch10SoundTouch14setTempoChangeEd in the file /usr/lib64/libSoundTouch.so.1.9.2.  soundtouch-1.9.2-3.fc23.x86_64 on my end.
Comment 2 Sylvia Sánchez 2016-02-22 14:13:02 EST
Same happens here.  I'm on Fedora 23 Cinnamon Spin. Just updated and I get this error:
audacity: symbol lookup error: audacity: undefined symbol: _ZN10soundtouch10SoundTouch14setTempoChangeEf
Comment 3 Devin Henderson 2016-02-25 18:09:36 EST
Should I change this bug to be against the "soundtouch" component?
Comment 4 Sylvia Sánchez 2016-02-26 09:21:13 EST
Looking closer to the error message, seems to me the problem is in Soundtouch really and not in Audacity as a whole.
So yes, Devin, I think you should change it.
Comment 5 Devin Henderson 2016-02-27 15:22:31 EST
Thanks Sylvia. I've updated the component.
Comment 6 Sergio Monteiro Basto 2016-02-27 15:33:37 EST
*** Bug 1311309 has been marked as a duplicate of this bug. ***
Comment 7 Sergio Monteiro Basto 2016-02-27 15:36:04 EST
Sorry I mess up , we need rebuild for new soundtouch 1.9.2 on F23 and F24 .

https://bugzilla.redhat.com/show_bug.cgi?id=1311295
Comment 8 Sergio Monteiro Basto 2016-02-27 15:44:40 EST
Until someone not rebuild audacity , you may downgrade soundtouch:

dnf downgrade "soundtouch*"
Comment 9 Sylvia Sánchez 2016-02-29 11:45:35 EST
Downgrading works fine. Thank you very much!
Comment 10 Sergio Monteiro Basto 2016-02-29 21:05:00 EST
we need rebuild and test audacity for new soundtouch 1.9.2 on F23 and F24
Comment 11 Benji Wiebe 2016-03-02 14:08:49 EST
I think audacity needs to be rebuilt. Soundtouch switched from floats to doubles internally. So soundtouch would have to be downgraded to get it to work, or audacity recompiled. Also, to me, floats -> doubles sounds like an improvement and I don't see the point in going back.
Comment 12 Sylvia Sánchez 2016-03-02 17:01:39 EST
I agree. By now, downgrading works but it's not a solution.  And as Benji says there's no point in going back.
So hope this get rebuilt ASAP.
Thanks!
Comment 13 Sergio Monteiro Basto 2016-03-03 00:15:41 EST
Hi,

To workaround, I built it in copr [1]:

dnf copr enable sergiomb/buildsforF21 
dnf update audacity

and we may test with soundtouch 1.9.2 , after that you may disable it:

dnf copr disable sergiomb/buildsforF21
rm /etc/yum.repos.d/_copr_sergiomb-buildsforF21.repo 

you won't need it anymore, sorry for the trouble . 


[1] https://copr.fedorainfracloud.org/coprs/sergiomb/buildsforF21/
Comment 14 Benji Wiebe 2016-03-03 01:25:09 EST
(In reply to Sergio Monteiro Basto from comment #13)
> Hi,
> 
> To workaround, I built it in copr [1]:
> 
> dnf copr enable sergiomb/buildsforF21 
> dnf update audacity
> 
> and we may test with soundtouch 1.9.2 , after that you may disable it:
> 
> dnf copr disable sergiomb/buildsforF21
> rm /etc/yum.repos.d/_copr_sergiomb-buildsforF21.repo 
> 
> you won't need it anymore, sorry for the trouble . 
> 
> 
> [1] https://copr.fedorainfracloud.org/coprs/sergiomb/buildsforF21/

This does work.
Comment 15 Fedora Update System 2016-03-03 14:29:12 EST
audacity-2.1.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee19511560
Comment 16 Fedora Update System 2016-03-04 21:23:09 EST
audacity-2.1.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee19511560
Comment 17 Fedora Update System 2016-03-05 17:21:33 EST
audacity-2.1.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Dennis Gilmore 2016-03-29 16:47:42 EDT
this is happening on f24
Comment 19 Sergio Monteiro Basto 2016-03-29 17:52:37 EDT
Audacity is FTBFS in rawhide (and F24) [1] that's why we still haven't the rebuild of audacity in F24 (and rawhide) .

[1] 
https://bugzilla.redhat.com/show_bug.cgi?id=1307335
Comment 20 Fedora Update System 2016-03-29 20:27:09 EDT
audacity-2.1.2-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfddbfb488
Comment 21 Fedora Update System 2016-03-30 18:26:13 EDT
audacity-2.1.2-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bfddbfb488
Comment 22 Fedora Update System 2016-04-02 11:54:43 EDT
audacity-2.1.2-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.