Bug 131052 - nfs mounted quotas broken on Solaris, panasas, and netapps
nfs mounted quotas broken on Solaris, panasas, and netapps
Status: CLOSED DUPLICATE of bug 123620
Product: Fedora
Classification: Fedora
Component: quota (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-08-26 18:32 EDT by Jay Hilliard
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:05:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jay Hilliard 2004-08-26 18:32:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
quota: Error while getting quota from host:/mount: Invalid argument

autofs is supposed to be able to ignore invalid arguments and still
work, but code in this package is NOT allowing invalid arguments. 
This causes quotas to fail on these particular mounts.

we want to ignore certain autofs options and continue to mount because
we have different automount clients out there (non linux) that need them

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Solaris exported filesystem with quotas turned on
2.automount map has "noquota" or other ugly options
3.Try to automount and you get the error

Actual Results:  quota: Error while getting quota from
fasrel-n1:/rel/sw for 2146: Invalid argument

Expected Results:  Ignore it and continue to mount anyway

Additional info:
Comment 1 Jay Hilliard 2004-09-10 15:40:11 EDT
this is a duplicate of 123620 which there is a fix for, but it's not
yet in fedora updates

*** This bug has been marked as a duplicate of 123620 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.