Bug 1310547 - [RFE] [Neutron] Neutron Layer 2 Gateway support
[RFE] [Neutron] Neutron Layer 2 Gateway support
Status: CLOSED DUPLICATE of bug 1431704
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Assaf Muller
Toni Freger
: FutureFeature
: 1310549 1369045 (view as bug list)
Depends On:
Blocks: 1265219 1281573 1389435 1396159 1414428 1431704
  Show dependency treegraph
 
Reported: 2016-02-22 03:25 EST by Marko Nousiainen
Modified: 2017-03-20 06:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-20 06:55:48 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Nousiainen 2016-02-22 03:25:20 EST
Integration of Neutron L2 GW to OSP:
https://wiki.openstack.org/wiki/Neutron/L2-GW

Our use case for L2 GW is to use VxLAN overlay for external connections instead of VLANs. This is achieved by having Neutron to manage VxLAN tunnel endpoints (VTEPs) on the physical switches as well as on the virtual switches on the hosts.

Discovering correct VTEP for destination MAC could be done with multicast, however Open vSwitch does not support this. Other way would be to have SDN controller with some application managing the VTEPs, but such applications are not generally available at the moment. Also L2 networks could be tunneled over L3 in a datacenter by configuring VTEPs on the leaf switches. This is however static and complex without SDN.

To have VXLAN overlay all the way from hosts to the edge of the cloud without multicasts or SDN, Neutron needs to have mapping of physical VTEPs in addition to host VTEPs with vSwitches. Neutron L2 GW implements this funtionality using OVSDB to configure VTEPs on the physical switches supporting it.

Use case somewhat similar to ours is demoed in this video:
https://www.youtube.com/watch?v=OJx2qKQijZ4
Comment 2 Assaf Muller 2016-06-04 10:03:53 EDT
*** Bug 1310549 has been marked as a duplicate of this bug. ***
Comment 3 Assaf Muller 2016-08-22 07:52:00 EDT
*** Bug 1369045 has been marked as a duplicate of this bug. ***
Comment 8 Nir Yechiel 2017-03-20 06:55:48 EDT

*** This bug has been marked as a duplicate of bug 1431704 ***

Note You need to log in before you can comment on or make changes to this bug.