Bug 1414428 - [RFE] [ODL] HW VTEP (L2 GW) support
Summary: [RFE] [ODL] HW VTEP (L2 GW) support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 12.0 (Pike)
Assignee: Victor Pickard
QA Contact: Itzik Brown
URL:
Whiteboard:
: 1411420 (view as bug list)
Depends On: 1310547 1422129 1431704 1434386 1469225 1476718
Blocks: 1389435 1402132 1442136 1469010 1533135 1533136
TreeView+ depends on / blocked
 
Reported: 2017-01-18 13:30 UTC by Nir Yechiel
Modified: 2018-10-18 07:25 UTC (History)
9 users (show)

Fixed In Version: opendaylight-6.1.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1533135 1533136 (view as bug list)
Environment:
N/A
Last Closed: 2017-12-13 21:02:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1659467 0 None None None 2017-05-17 17:58:21 UTC
Launchpad 1686799 0 None None None 2017-05-17 18:04:18 UTC
OpenDaylight Bug 7669 0 None None None 2017-05-17 17:54:15 UTC
OpenDaylight Bug 7743 0 None None None 2017-05-17 18:08:27 UTC
OpenDaylight Bug 7744 0 None None None 2017-05-17 18:06:34 UTC
OpenDaylight Bug 8376 0 None None None 2017-05-17 18:09:05 UTC
OpenDaylight Bug 8476 0 None None None 2017-05-17 18:10:56 UTC
OpenDaylight gerrit 50966 0 None None None 2017-05-17 17:55:46 UTC
OpenDaylight gerrit 54344 0 None None None 2017-05-17 18:07:05 UTC
OpenDaylight gerrit 56544 0 None None None 2017-05-17 18:09:38 UTC
OpenDaylight gerrit 57210 0 None None None 2017-05-17 18:11:38 UTC
OpenDaylight gerrit 57211 0 None None None 2017-05-17 18:11:57 UTC
OpenStack gerrit 461136 0 None None None 2017-05-17 18:05:16 UTC
OpenStack gerrit 466753 0 None None None 2017-06-08 14:12:02 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Nir Yechiel 2017-01-18 13:30:29 UTC
Description of problem:

Layer 2 gateway services allow a tenant’s virtual network to be bridged to a physical network. This integration provides users with the capability to access resources on a physical server via a layer 2 network connection rather than via a routed layer 3 connection, i.e extending the L2 broadcast domain instead of going through L3/Floating IP.

To implement this, there is a need to bridge between the virtual workloads running inside an overlay (VXLAN) and workloads running in physical networks (normally using VLAN).

The idea behind hardware VTEPs is to create an overlay network that connects VMs and physical servers and make them think that they’re in the same L2 network even if they’re on opposite sides of the globe. OpenDaylight will manipulate specific OVSDB databases on the VTEP. The database that the controller manipulates will vary depending on the VTEP’s type: if the VTEP is a hypervisor, the controller will expect to manipulate an Open_vSwitch database. If the VTEP is a hardware VTEP, it will expect to manipulate a hardware_vtep database. In both cases, the controller will manipulate the DB using the OVSDB protocol.

Neutron has an L2 GW API: http://docs.openstack.org/developer/networking-l2gw/usage.html

Comment 1 Nir Yechiel 2017-03-20 10:47:43 UTC
*** Bug 1411420 has been marked as a duplicate of this bug. ***

Comment 3 Nir Yechiel 2017-06-26 12:15:34 UTC
We think that we can provide the best experience to our customers by offering a certification process for HW VTEP on specific switch models. We won’t fully support the feature until such a certification process exists. 

HW VTEP with OpenDaylight will be offered as technology preview for RHOSP 12.

Comment 11 errata-xmlrpc 2017-12-13 21:02:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Comment 12 Victor Pickard 2018-01-15 15:16:00 UTC
I have provided doc input and review. All done with doc requirements as far at I can tell. Please let me know if that is not the case.


Note You need to log in before you can comment on or make changes to this bug.