Bug 1310620 - gfapi : listxattr is broken for handle ops.
Summary: gfapi : listxattr is broken for handle ops.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: All
OS: All
medium
medium
Target Milestone: ---
Assignee: Jiffin
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: 1311411
TreeView+ depends on / blocked
 
Reported: 2016-02-22 11:30 UTC by Jiffin
Modified: 2016-06-16 13:58 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1311411 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:58:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jiffin 2016-02-22 11:30:35 UTC
Description of problem:
listxattr is called as part of glfs_h_getxattrs() when NULL is passed to name field. but glfs_h_getxattrs_common() inside it will error out if name is NULL

Comment 1 Vijay Bellur 2016-02-22 11:34:35 UTC
REVIEW: http://review.gluster.org/13482 (gfapi : fixing listxattr call for handle ops) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 2 Vijay Bellur 2016-02-22 12:24:04 UTC
REVIEW: http://review.gluster.org/13482 (gfapi : fixing listxattr call for handle ops) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 3 Vijay Bellur 2016-02-23 12:49:40 UTC
COMMIT: http://review.gluster.org/13482 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 0bc54f3ea7a56040df4a67b8626200b47fa3d779
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Feb 22 16:50:12 2016 +0530

    gfapi : fixing listxattr call for handle ops
    
    Currently listxattr is called as part of glfs_h_getxattrs() when NULL is
    passed to name field, but glfs_h_getxattrs_common() inside it will error
    out if name is NULL. Therefore listxattr is broken for handle ops.
    
    Change-Id: I9ced6e33525e1e1a50298972e4922c954fc2b223
    BUG: 1310620
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13482
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 4 Niels de Vos 2016-06-16 13:58:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.