Bug 1311411 - gfapi : listxattr is broken for handle ops.
gfapi : listxattr is broken for handle ops.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.7.9
All All
medium Severity medium
: ---
: ---
Assigned To: Jiffin
Sudhir D
:
Depends On: 1310620
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 03:07 EST by Jiffin
Modified: 2016-04-19 03:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1310620
Environment:
Last Closed: 2016-04-19 03:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2016-02-24 03:07:38 EST
+++ This bug was initially created as a clone of Bug #1310620 +++

Description of problem:
listxattr is called as part of glfs_h_getxattrs() when NULL is passed to name field. but glfs_h_getxattrs_common() inside it will error out if name is NULL

--- Additional comment from Vijay Bellur on 2016-02-22 06:34:35 EST ---

REVIEW: http://review.gluster.org/13482 (gfapi : fixing listxattr call for handle ops) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-22 07:24:04 EST ---

REVIEW: http://review.gluster.org/13482 (gfapi : fixing listxattr call for handle ops) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-23 07:49:40 EST ---

COMMIT: http://review.gluster.org/13482 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 0bc54f3ea7a56040df4a67b8626200b47fa3d779
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Feb 22 16:50:12 2016 +0530

    gfapi : fixing listxattr call for handle ops
    
    Currently listxattr is called as part of glfs_h_getxattrs() when NULL is
    passed to name field, but glfs_h_getxattrs_common() inside it will error
    out if name is NULL. Therefore listxattr is broken for handle ops.
    
    Change-Id: I9ced6e33525e1e1a50298972e4922c954fc2b223
    BUG: 1310620
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13482
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 1 Vijay Bellur 2016-02-24 03:09:11 EST
REVIEW: http://review.gluster.org/13504 (gfapi : fixing listxattr call for handle ops) posted (#1) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)
Comment 2 Vijay Bellur 2016-02-25 14:58:23 EST
COMMIT: http://review.gluster.org/13504 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit b29822556d7ba83dc229d57eb29e141fc27b025e
Author: Jiffin Tony Thottan <jthottan@gmail.com>
Date:   Mon Feb 22 16:50:12 2016 +0530

    gfapi : fixing listxattr call for handle ops
    
    Currently listxattr is called as part of glfs_h_getxattrs() when NULL is
    passed to name field, but glfs_h_getxattrs_common() inside it will error
    out if name is NULL. Therefore listxattr is broken for handle ops.
    
    Upstream reference
    >Change-Id: I9ced6e33525e1e1a50298972e4922c954fc2b223
    >BUG: 1310620
    >Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    >Reviewed-on: http://review.gluster.org/13482
    >Reviewed-by: Niels de Vos <ndevos@redhat.com>
    >Smoke: Gluster Build System <jenkins@build.gluster.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    >(cherry picked from commit 0bc54f3ea7a56040df4a67b8626200b47fa3d779)
    
    Change-Id: Ib88c12e5c2a1841e96a65e672f40b44ac9f491a9
    BUG: 1311411
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/13504
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:50:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Kaushal 2016-04-19 03:23:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.