Bug 1310622 - Missing bits from mariadb-galera
Missing bits from mariadb-galera
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
24
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jakub Dorňák
Fedora Extras Quality Assurance
:
Depends On:
Blocks: RDO-MITAKA/RDO-MITAKA-REVIEWS
  Show dependency treegraph
 
Reported: 2016-02-22 06:35 EST by hguemar
Modified: 2016-04-20 11:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: mariadb-10.1.12-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 11:26:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hguemar 2016-02-22 06:35:37 EST
Description of problem:
Missing bits from mariadb-galera like clustercheck
http://pkgs.fedoraproject.org/cgit/rpms/mariadb-galera.git/tree/clustercheck.sh?id=711b7046844cc4baab68f52d62991b288d71858d

It breaks OpenStack TripleO
https://bugs.launchpad.net/tripleo/+bug/1547660?comments=all

Version-Release number of selected component (if applicable):
10.1.11-9.el7

How reproducible:
always

Steps to Reproduce:
1. install mariadb
2. run tripleo
3. see it fail

Actual results:
failure due to missing bits

Expected results:
clustercheck should be available

Additional info:
Comment 1 Damien Ciabrini 2016-02-23 06:42:21 EST
latest version of package galera provides WSREP replication and consequently mariadb-galera has been obsoleted in
https://bugzilla.redhat.com/show_bug.cgi?id=1306912 

We still require clustercheck though, as it is the usual way for clients to check whether a galera node is running and in sync.

looking at http://pkgs.fedoraproject.org/cgit/rpms/mariadb-galera.git/tree/?id=711b7046844cc4baab68f52d62991b288d71858d, we need at least
clustercheck
LICENSE.clustercheck

There is also a specific config file galera.cnf for WSREP settings. I'm currently trying to figure out if we need that file as well or if settings are available in another config file already present in package mariadb.
Comment 2 Jan Kurik 2016-02-24 10:47:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 hguemar 2016-03-21 10:27:33 EDT
Any feedback?
Comment 4 Damien Ciabrini 2016-03-21 10:51:50 EDT
There is at least another setting to be changed in mariadb10 configuration file to enable galera replication [1]. This was implicit on mariadb 5.5 as soon as option wsrep_provider was set.

Once the mariadb setting will be updated, one needs to discuss how to retrofit bits from #c1 to allow galera replication with mariadb10.
Comment 5 Jakub Dorňák 2016-03-22 05:43:32 EDT
Hi, I plan to add subpackage mariadb-galera-server, which should obsolete the original mariadb-galera-server package and provide these bits.
Would that be OK for You?
Comment 6 Alan Pevec 2016-03-22 19:48:12 EDT
@Jakub works for me, that seems to be clean way to resolve this part of the upgrade issue.

@Damien link [1] is missing in your comment 4 ? What do you mean by retrofit?
Comment 7 Damien Ciabrini 2016-03-23 03:43:23 EDT
Woops, the missing link from comment 4 was 

https://mariadb.com/kb/en/mariadb/galera-cluster-system-variables/#wsrep_on

Alan, Jakub, we need two things in order to make mariadb 10 works with tripleo.

One is to the include the missing clustercheck bits in some package. @Jakub do 
you mean that mariadb would now generate the subpackage mariadb-galera-server?

The second thing is with MariaDB 10, one needs to change the galera generated config in tripleo-heat-template to set wsrep_on to ON, otherwise the galera replication will not engage and stack creation will fail. I'll prepare a patch for that one.
Comment 9 Fedora Update System 2016-03-23 04:16:06 EDT
mariadb-10.1.12-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4cdec834ef
Comment 10 hguemar 2016-03-23 08:11:48 EDT
Jakub and Damien, thank you :)
Comment 11 Fedora Update System 2016-03-23 15:56:07 EDT
mariadb-10.1.12-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4cdec834ef
Comment 12 Fedora Update System 2016-03-24 05:22:12 EDT
mariadb-10.1.12-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e4d9584d94
Comment 13 Fedora Update System 2016-03-25 16:28:24 EDT
mariadb-10.1.12-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e4d9584d94
Comment 14 Fedora Update System 2016-04-20 11:26:03 EDT
mariadb-10.1.12-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.