Bug 1310624 - events are flooded with 'Refresh image list succeeded for domain(s):' when console is open
events are flooded with 'Refresh image list succeeded for domain(s):' when co...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-viewer (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Eduardo Lima (Etrunko)
:
Depends On:
Blocks: 1347726 1358809
  Show dependency treegraph
 
Reported: 2016-02-22 06:40 EST by Shira Maximov
Modified: 2017-02-13 09:41 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, opening a remote guest console with the remote-viewer utility in the Red Hat Enterprise Virtualization Manager caused the event log to be flooded with the "Refresh image list succeeded for domain(s)" message. This update significantly lowers the frequency of displaying messages about refreshing image list, so that they no longer flood the guest event log.
Story Points: ---
Clone Of:
: 1347726 (view as bug list)
Environment:
Last Closed: 2017-02-13 09:41:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
event print screen (90.66 KB, image/png)
2016-02-22 06:40 EST, Shira Maximov
no flags Details
engine.log (1.23 MB, text/plain)
2016-02-22 06:45 EST, Shira Maximov
no flags Details

  None (edit)
Description Shira Maximov 2016-02-22 06:40:01 EST
Created attachment 1129236 [details]
event print screen

Description of problem:
due to foreign menu feature the events are folded with " Refresh image list succeeded for domain(s): XXX (All file type) event. 


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.6.3.2-0.1.el6 


How reproducible:
100%

Steps to Reproduce:
1.connect to webadmin (with fqdn)
2.open console to a running VM and look at the events

Actual results:


Expected results:


Additional info:
Comment 1 Shira Maximov 2016-02-22 06:43:05 EST
note: an ISO domain should be attached.
Comment 2 Shira Maximov 2016-02-22 06:45 EST
Created attachment 1129251 [details]
engine.log

the engine log is also flooded .
Comment 3 Michal Skrivanek 2016-02-23 00:53:39 EST
HA reservation status log every 5s should also be tackled
Comment 4 Michal Skrivanek 2016-02-24 07:16:06 EST
It shouldn't be so often, right?
Comment 5 Christophe Fergeau 2016-02-29 11:17:59 EST
iirc remote-viewer is getting the ISO list every 5 seconds.
As I could not find a way to get a notification when a new ISO appears, I had to make a guess as to how long a user will accept to wait for an ISO to appear in the foreign menu after it's added to the ISO domain.
Comment 6 Michal Skrivanek 2016-02-29 11:48:04 EST
Well, I wouldn't do that unless someone opens the menu. Would that be a big change? It's a small delay, but I think it's better than refreshing so often. Otherwise this can be used as a keepalive mechanism:) what do you think?
Comment 7 Christophe Fergeau 2016-02-29 12:03:28 EST
I think (haven't tested) the menu is going to get closed if something changes while the menu is opened. And I don't think that's a very good UI if you want to use an ISO you just added to the domain, especially if the connection to the ovirt instance is slow.
But apart from your suggestion or the current polling, I can't really think of a smart way of doing things (well, apart from getting events from oVirt but I'm not holding my breath for that ;)
Comment 8 Tomas Jelinek 2016-03-01 03:56:39 EST
But imagine we have hundreds of clients concurrently accessing the VMs using remote viewer. Only the amount of data transferred over the line every 5 seconds is going to be significant. Not to mention the additional load on the engine side.

Any chance you could investigate a bit more the Michal's suggestion with loading only when the menu opens? Because we are not getting events in near future for sure even we all would love to see them :)
Comment 9 Christophe Fergeau 2016-03-01 09:10:45 EST
We could do the refresh much less often (how often would be acceptable ? every 5 minutes ?) and have Michal's suggestion as a poor-man's refresh. But in situations like in bug #1310450 (look at CD menu, disable ISO damain, look at CD menu), things are going to be odd.
Comment 10 Tomas Jelinek 2016-03-02 03:00:45 EST
Every 5 minutes sounds good enough - you typically don't change the content of the ISO domain too often.
What you mean by odd? The fact that you will see one CD in the menu and when open than it will disappear? Or something else?
Comment 11 Christophe Fergeau 2016-03-02 04:25:00 EST
(In reply to Tomas Jelinek from comment #10)
> What you mean by odd? The fact that you will see one CD in the menu and when
> open than it will disappear? Or something else?

I'm not fully sure about the exact behaviour if the list changes while the menu is opened. But if you are on a slow link and add a new ISO that you want to use, 
you'll open the menu, the ISO is not there, you wait a bit, open the menu (assuming you decide to try again!), the ISO is magically there. That's very unexpected ;)
Comment 12 Tomas Jelinek 2016-03-11 08:49:03 EST
(In reply to Christophe Fergeau from comment #11)
> you'll open the menu, the ISO is not there, you wait a bit, open the menu
> (assuming you decide to try again!), the ISO is magically there. That's very
> unexpected ;)

than the only thing I can think of is a specific "refresh" button in the menu. Not beautiful but at least no polling needed at all and the user will know why did the new ISO magically appeared.
Comment 13 Christophe Fergeau 2016-03-11 11:41:27 EST
I think we can go with the suggestion from comment #9, but I'm not going to be hugely enthusiastic when bugs are reported against this behaviour...
Comment 14 Tomas Jelinek 2016-03-14 04:08:02 EDT
(In reply to Christophe Fergeau from comment #13)
> I think we can go with the suggestion from comment #9, but I'm not going to
> be hugely enthusiastic when bugs are reported against this behaviour...

if there could be some kind of a loading indicator somewhere indicating that you are loading the new list the behavior would be much less odd. Do you think you could put it somewhere?
Comment 15 Tomas Jelinek 2016-04-06 03:08:27 EDT
@Christophe: so how have you decided?
Comment 16 Eduardo Lima (Etrunko) 2016-06-17 08:14:40 EDT
So, this is a virt-viewer issue, yes. I will investigate a way of doing this check only on demand, or as last resource We could adopt the longer timer for a quick fix.
Comment 17 Eduardo Lima (Etrunko) 2017-01-17 08:57:31 EST
I posted patch series to the mailing list replacing the menu item with a dedicated dialog for this task.

https://www.redhat.com/archives/virt-tools-list/2017-January/msg00023.html
Comment 18 Eduardo Lima (Etrunko) 2017-02-13 09:41:06 EST
Code is now upstream, Change CD is now under "File" menu and it shows the ISO list as a dialog.

Note You need to log in before you can comment on or make changes to this bug.