Bug 1310798 - Eclipse JVM crashes in libwebkitgtk-3.0.so.0::webkit_web_view_draw(_GtkWidget*, _cairo*)
Eclipse JVM crashes in libwebkitgtk-3.0.so.0::webkit_web_view_draw(_GtkWidget...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: webkitgtk3 (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 11:52 EST by Waldemar Pilecki
Modified: 2016-02-23 04:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 03:47:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hs file (151.52 KB, text/plain)
2016-02-22 11:52 EST, Waldemar Pilecki
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1250870 None None None 2016-02-23 04:57 EST
WebKit Project 154532 None None None 2016-02-22 11:52 EST

  None (edit)
Description Waldemar Pilecki 2016-02-22 11:52:30 EST
Created attachment 1129407 [details]
hs file

Description of problem: Eclipse crashes during browsing OpenJDK javadoc with internal browser.


Version-Release number of selected component (if applicable):
webkitgtk3-2.4.9-3.fc23.x86_64 - it is current release for F23. It seems it's unsupported from webkit.org fols point of view.

How reproducible:
Always

Steps to Reproduce:
1.run Eclipse
2.Window->Preferences->Java-Installed JREs->Edit->rt.jar->Javadoc location
3.enter file:///usr/share/javadoc/java-1.8.0-openjdk-1.8.0.72-4.b15.fc23/api
4.try to display javadoc for some class

Actual results:
crash Eclipse

Expected results:
display javadoc in new Eclipse window

Additional info:
Opened ticket Bug 154532 at webkit.org, they sad "Since you are using an old, unsupported, and insecure version of WebKit, it's very unlikely that anyone will investigate this".
Comment 1 Kevin Fenzi 2016-02-22 12:48:25 EST
Moving to the actual correct component. ;)
Comment 2 Tomas Popela 2016-02-23 03:47:25 EST
(In reply to Waldemar Pilecki from comment #0)
> Created attachment 1129407 [details]
> hs file

In the hs file I see: 

 # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

so please follow the instructions there and try to provide a better backtrace. Also please provide the info to the upstream bug.

> Opened ticket Bug 154532 at webkit.org, they sad "Since you are using an
> old, unsupported, and insecure version of WebKit, it's very unlikely that
> anyone will investigate this".

Upstream is true about the WebKit version you are using. Also there is no need to have a downstream bug if there is already an upstream one.

Note You need to log in before you can comment on or make changes to this bug.