Bug 1310895 - Adding a duplicate Foreman provider name never redirects to the flash message
Adding a duplicate Foreman provider name never redirects to the flash message
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Drew Bomhof
Jan Krocil
foreman:ui
: ZStream
Depends On:
Blocks: 1312046
  Show dependency treegraph
 
Reported: 2016-02-22 17:50 EST by Drew Bomhof
Modified: 2016-06-29 11:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1312046 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Drew Bomhof 2016-02-22 17:50:18 EST
Description of problem:

When attempting to add a Foreman provider that is a duplicate of an existing provider - the UI will never redirect to show the flash messages.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Create a Foreman provider
2. Create a second Foreman provider that exactly matches the first
3. Stacktrace in the server log errors with: Render and/or redirect were called multiple times in this action - UI never finishes loading.


Expected results:

UI should redirect to provider page showing flash messages


Additional info:
Comment 3 CFME Bot 2016-02-29 16:55:54 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ce87161340b82a63b90fb20546f15005f0e9e379

commit ce87161340b82a63b90fb20546f15005f0e9e379
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Mon Feb 29 15:07:16 2016 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Mon Feb 29 15:07:16 2016 -0500

    Move replace_right_cell out of the errors conditional
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310895

 app/controllers/provider_foreman_controller.rb       |  2 +-
 spec/controllers/provider_foreman_controller_spec.rb | 13 +++++++++++++
 2 files changed, 14 insertions(+), 1 deletion(-)
Comment 4 CFME Bot 2016-03-01 15:51:31 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=0232849a5941d31e1a1f8d230d53e5ec2bfd3b9c

commit 0232849a5941d31e1a1f8d230d53e5ec2bfd3b9c
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Mon Feb 29 15:07:16 2016 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Tue Mar 1 10:01:25 2016 -0500

    Move replace_right_cell out of the errors conditional
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1310895

 app/controllers/provider_foreman_controller.rb       |  2 +-
 spec/controllers/provider_foreman_controller_spec.rb | 13 +++++++++++++
 2 files changed, 14 insertions(+), 1 deletion(-)
Comment 5 Jan Krocil 2016-04-19 09:45:54 EDT
Verified fixed in 5.6-beta2 - 5.6.0.1-beta2.20160413141124_e25ac0e.
Flash message is now correctly shown when trying to add a duplicate provider.
Comment 7 errata-xmlrpc 2016-06-29 11:38:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.