Bug 1312046 - Adding a duplicate Foreman provider name never redirects to the flash message
Adding a duplicate Foreman provider name never redirects to the flash message
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: Drew Bomhof
Jan Krocil
: ZStream
Depends On: 1310895
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 10:32 EST by Chris Pelland
Modified: 2017-08-29 21:36 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1310895
Environment:
Last Closed: 2016-04-13 14:45:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2016-03-01 15:51:34 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cf17bb340fe922fe7259e629a239b80ccbb1e480

commit cf17bb340fe922fe7259e629a239b80ccbb1e480
Merge: fe3d85a 0232849
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Mar 1 15:33:16 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Mar 1 15:33:16 2016 -0500

    Merge branch '5.5.z_duplicate_foreman_provider' into '5.5.z'
    
    Move replace_right_cell out of the errors conditional
    
    Upstream BZ https://bugzilla.redhat.com/show_bug.cgi?id=1310895
    
    PR https://github.com/ManageIQ/manageiq/pull/7015
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1312046
    
    Needed to modify instance_variable, flash text for the tests to pass.
    
    See merge request !825

 app/controllers/provider_foreman_controller.rb       |  2 +-
 spec/controllers/provider_foreman_controller_spec.rb | 13 +++++++++++++
 2 files changed, 14 insertions(+), 1 deletion(-)
Comment 3 Jan Krocil 2016-03-29 10:02:04 EDT
Failed QA on 5.5.3.2 - 5.5.3.2.20160318152106_92d2d67.

The provider cannot be added twice anymore (this part is fixed) but it spawns 4 flash errors with sort of duplicate and incorrect text.

See attachment (left image is for configuration managers)

Also see related https://bugzilla.redhat.com/show_bug.cgi?id=1317892
Comment 5 Drew Bomhof 2016-03-31 12:08:42 EDT
Hi Jan,

Configuration Manager providers require additional field validation than infra providers, that being said, the resulting four flash errors are correct for that provider.

Seeing that the main bug (system hangs) was solved and is merged, we would like to see a new BZ created to address the UI changes. 

We would have to revamp how validation errors are returned when the reported event is attempted with this provider type.
Comment 6 Jan Krocil 2016-04-04 13:16:41 EDT
Ok, closing as verified in 5.5.3.2.
There is a separate BZ for the error mentioned above.
Comment 8 errata-xmlrpc 2016-04-13 14:45:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.