Bug 1310926 - Add %pre-install patch
Add %pre-install patch
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pykickstart (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: 7.3
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks: 1274917 1311184
  Show dependency treegraph
 
Reported: 2016-02-22 19:41 EST by Ben Woodard
Modified: 2016-11-03 20:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: pykickstart-1.99.66.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1311184 (view as bug list)
Environment:
Last Closed: 2016-11-03 20:11:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Woodard 2016-02-22 19:41:06 EST
Description of problem:
Can we please backport commit 31b0b8b10094a017ba4a3d62c15cfae59fc54146 from 2.6-1. This is useful for LLNL's custom build. This will allow them to inject our password/group files after /mnt/sysimage is mounted and before packages are installed.

Version-Release number of selected component (if applicable): 1.99.66.6-1
Comment 4 Chris Lumens 2016-02-23 09:49:26 EST
You meant pre-install, right?

Yeah this looks doable for 7.3.  I don't see anything tricky about it and doing a test cherry-pick shows only a couple conflicts that are easily solved.  We'll need a bug to do the anaconda portion too.  I'll clone this right up.
Comment 5 Ben Woodard 2016-02-23 11:00:34 EST
Doh! Yes it is pre-install, that was a thinko on my part.
Comment 8 Ben Woodard 2016-03-21 15:06:25 EDT
LLNL is asking for a pre-release or hot fix for this.
Comment 11 errata-xmlrpc 2016-11-03 20:11:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2184.html

Note You need to log in before you can comment on or make changes to this bug.