Bug 1311124 - Implement inode_forget_cbk() similar fops in gfapi
Implement inode_forget_cbk() similar fops in gfapi
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
All All
unspecified Severity medium
: ---
: ---
Assigned To: Soumya Koduri
Sudhir D
: Triaged
Depends On:
Blocks: 1311445
  Show dependency treegraph
 
Reported: 2016-02-23 07:53 EST by Soumya Koduri
Modified: 2016-06-16 09:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1311445 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:58:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2016-02-23 07:53:54 EST
Description of problem:
We do not have implementation for cbk fops like forget(), release() and releasedir() in gfapi xlator. This bug is to track the changes. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-23 07:59:15 EST
REVIEW: http://review.gluster.org/13498 (libglusterfs: Change log-level to DEBUG for default_* fops()) posted (#1) for review on master by soumya k (skoduri@redhat.com)
Comment 2 Vijay Bellur 2016-02-23 07:59:17 EST
REVIEW: http://review.gluster.org/13499 (gfapi: Add xlator_cbks fops in gfapi) posted (#1) for review on master by soumya k (skoduri@redhat.com)
Comment 3 Vijay Bellur 2016-02-23 13:47:27 EST
COMMIT: http://review.gluster.org/13498 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 730ea2ca509a5bea05726090cd1e4cb67f040b7c
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Tue Feb 23 18:10:36 2016 +0530

    libglusterfs: Change log-level to DEBUG for default_* fops()
    
    Change-Id: I7087476bbc00cd23ba65ea119bc0fe8a9bff347d
    BUG: 1311124
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13498
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Vijay Bellur 2016-02-23 19:59:19 EST
COMMIT: http://review.gluster.org/13499 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit dcb13de77d0ac056b588f3eb7414e33afeeb3629
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Tue Feb 23 18:27:09 2016 +0530

    gfapi: Add xlator_cbks fops in gfapi
    
    Change-Id: I1fe5dd757e65206f92e0a867b43b49a3c0f2d4cf
    BUG: 1311124
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13499
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 5 Niels de Vos 2016-06-16 09:58:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.