Bug 1311445 - Implement inode_forget_cbk() similar fops in gfapi
Implement inode_forget_cbk() similar fops in gfapi
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.7.9
All All
unspecified Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
Sudhir D
: Triaged
Depends On: 1311124
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-24 04:39 EST by Soumya Koduri
Modified: 2016-04-19 03:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1311124
Environment:
Last Closed: 2016-04-19 03:22:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2016-02-24 04:39:18 EST
+++ This bug was initially created as a clone of Bug #1311124 +++

Description of problem:
We do not have implementation for cbk fops like forget(), release() and releasedir() in gfapi xlator. This bug is to track the changes. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-02-23 07:59:15 EST ---

REVIEW: http://review.gluster.org/13498 (libglusterfs: Change log-level to DEBUG for default_* fops()) posted (#1) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-23 07:59:17 EST ---

REVIEW: http://review.gluster.org/13499 (gfapi: Add xlator_cbks fops in gfapi) posted (#1) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-23 13:47:27 EST ---

COMMIT: http://review.gluster.org/13498 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 730ea2ca509a5bea05726090cd1e4cb67f040b7c
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Tue Feb 23 18:10:36 2016 +0530

    libglusterfs: Change log-level to DEBUG for default_* fops()
    
    Change-Id: I7087476bbc00cd23ba65ea119bc0fe8a9bff347d
    BUG: 1311124
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13498
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

--- Additional comment from Vijay Bellur on 2016-02-23 19:59:19 EST ---

COMMIT: http://review.gluster.org/13499 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit dcb13de77d0ac056b588f3eb7414e33afeeb3629
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Tue Feb 23 18:27:09 2016 +0530

    gfapi: Add xlator_cbks fops in gfapi
    
    Change-Id: I1fe5dd757e65206f92e0a867b43b49a3c0f2d4cf
    BUG: 1311124
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13499
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 1 Vijay Bellur 2016-02-24 04:48:52 EST
REVIEW: http://review.gluster.org/13508 (gfapi: Add xlator_cbks fops in gfapi) posted (#1) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 2 Vijay Bellur 2016-02-26 00:18:39 EST
REVIEW: http://review.gluster.org/13508 (gfapi: Add xlator_cbks fops in gfapi) posted (#2) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 3 Vijay Bellur 2016-02-28 05:37:53 EST
REVIEW: http://review.gluster.org/13508 (gfapi: Add xlator_cbks fops in gfapi) posted (#3) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 4 Vijay Bellur 2016-02-29 07:01:29 EST
COMMIT: http://review.gluster.org/13508 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit c2b565904c9d2fdcb30ae21b5d77464415a05cd1
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Tue Feb 23 18:27:09 2016 +0530

    gfapi: Add xlator_cbks fops in gfapi
    
    This is backport of the below fix -
     http://review.gluster.org/13499
    
    Change-Id: I1fe5dd757e65206f92e0a867b43b49a3c0f2d4cf
    BUG: 1311445
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13499
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/13508
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 5 Kaushal 2016-04-19 03:22:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.