Bug 131114 - Hang when PPPoE gets started on boot
Hang when PPPoE gets started on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 131949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-27 13:53 EDT by Pekka Pietikäinen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: udev-030-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-07 06:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2004-08-27 13:53:42 EDT
Description of problem:

This could actually be initscripts, ppp, udev, mkinitrd or dev, but
filing it under initscripts since that's what gets stuck.

mkinitrd-4.1.6-1
udev-030-7
package dev is not installed (yum upgrade failed since it thought /dev
was devfs and nuked it!)
initscripts-7.71-1
ppp-2.4.2-4

[root@the RPMS]# more /etc/sysconfig/network-scripts/ifcfg-Baana
...
ONBOOT=yes
DEVICE=ppp0
PROVIDER=Baana
LINUX_PLUGIN=rp-pppoe.so

like this when networking is started, the system just gets stuck
there, the alt-sysrq keys don't report anything useful etc.
ONBOOT=no and ifuping it in rc.local works but it has
to try it a few times:

Aug 26 19:30:18 the kernel: CSLIP: code copyright 1989 Regents of the
University of California
Aug 26 19:30:18 the kernel: PPP generic driver version 2.4.2
Aug 26 19:30:18 the kernel: NET: Registered protocol family 24
Aug 26 19:30:18 the kernel: HDLC line discipline: version $Revision:
4.8 $, maxframe=4096
Aug 26 19:30:18 the kernel: N_HDLC line discipline registered.
Aug 26 19:30:18 the pppd[3592]: Plugin rp-pppoe.so loaded.
Aug 26 19:30:18 the pppd[3592]: Linux kernel does not support PPPoE --
are you running 2.4.x?
Aug 26 19:30:18 the pppd[3592]: Exit.
Aug 26 19:30:18 the adsl-connect: ADSL connection lost; attempting
re-connection.
Aug 26 19:30:19 the udev[3596]: creating device node '/dev/ppp'
Aug 26 19:30:23 the pppd[3603]: Plugin rp-pppoe.so loaded.
Aug 26 19:30:23 the pppd[3603]: RP-PPPoE plugin version 3.3 compiled
against pppd 2.4.2
Aug 26 19:30:23 the pppd[3603]: pppd 2.4.2 started by root, uid 0
Aug 26 19:30:23 the pppd[3603]: PPP session is 47388

Problem could be a missing /dev/ppp. syslog isn't up at that point
so debugging is a bit nasty. Could change the ordering I suppose...
Comment 1 Pekka Pietikäinen 2004-08-27 14:05:20 EDT
Blah... recreating the mkinitrd or something todays rawhide actually
fixed this problem. The dev-getting-nuked is a bug I suppose, but
things work just fine without it so... :-)
Comment 2 Pekka Pietikäinen 2004-09-04 05:34:37 EDT
Bug is back, moving syslog before networking shows the 
system goes into a (this from the old log but the messages are the
same :-) )

Aug 26 19:30:18 the pppd[3592]: Plugin rp-pppoe.so loaded.
Aug 26 19:30:18 the pppd[3592]: Linux kernel does not support PPPoE --
are you running 2.4.x?
Aug 26 19:30:18 the pppd[3592]: Exit.
Aug 26 19:30:18 the adsl-connect: ADSL connection lost; attempting
re-connection.

loop, after all initscripts have run udev seems to notice it should be
creating /dev/ppp and what happens is like in the log above,  I'm
still not sure what conditions are required for that to happen though.

initscripts-7.77-1
udev-030-20
ppp-2.4.2-4
mkinitrd-4.1.9-1
dev-3.11-1

Not sure which component should be responsible for creating it,
/sbin/kmodule & rc.sysinit from initscripts or udev_start/startudev 
from udev?

Comment 3 Bill Nottingham 2004-09-06 16:53:55 EDT
udev, AFAIK.
Comment 4 Harald Hoyer 2004-09-07 06:19:33 EDT
*** Bug 131949 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.